Looking for P4 patch for BeOS/dano


#1

Hi,
I am trying to boot dano on a P4, the system reboots when it gets to the 2nd icon, where can i find this patch?, i found the one for the Athlon and the kptach one which is also for amd but not this one.


#2

Dano supports only 768 MB of RAM, maybe problemm is there?


#3

It could be, i have 1 GB of RAM, i thought the limit was 1 GB or am i mistaking? i don’t have a video card with its own RAM, so i thought this was fine, was there a fix for this? it’s been a long time since i tried to boot BeOS/dano.


#4

IIRC 768 or even 512 MB was the limit indeed.

Regarding patches, maybe you could find some here:
http://pulkomandy.tk/~beosarchive/unsorted/BeBits_2010-12-20/beos.mlotz.ch/
Or here:
http://pulkomandy.tk/~beosarchive/unsorted/BDifferent/System/Kernel%2BSystem%20Patches/

Maybe check the cpu_fix and system_time_patch, IIRC there was an issue with CPU above 2Ghz…

I really don’t remember the tricky details, it was so long ago that I booted BeOS…


#5

Yes, you’re right both of you, the limit is 768 MB, i’ll check all this info out, thanks alot both of you.


#6

I remember that one had also to consider the video memory for the total amount of memory “seen” by BeOS.

A main memory of 512 MB was considered to be the practical limit with high end video cards from that era having 128 or 256 MB. I remember a note about an issue with some ATI cards reporting/reserving 256 MB of memory.

I don’t recall if systems mapping their video memory into the main memory were on the market when Dan0 began circulating around.


#7

Thanks to the links Phoudoin gave me, i got past that memory limit by copying the zbeos to the BeOS.iso, i performed the installation by mounting the iso image in haiku and used the installer, it seemed to have gone smoothly, but now i hit another problem, the boot process stops with the infamous error message “unable to find boot volume on /dev/disk/ata/x/x/x”, my drive is a 500 GB sata 1rst gen one, i think there was another problem with large HDD’s back then as well, right?.


#8

No SATA support in dano nor r5, only in zeta and some updated from zeta for r5 kernels. You can try setting SATA to emulate IDE ATA drive in BIOS if there is such option.


#9

Thanks for the confirmation, i suspected that too to be the reason, it looks like my luck ran out too fast, no such option in my bios.


#10

Well, either you find an old IDE disk, or you get these SATA to IDE converter, like this one;
https://fr.aliexpress.com/item/1x-for-Laptop-2-5-Hard-Drive-HDD-22PIN-SATA-female-to-IDE-44Pin-Converter-Adapter/32728997396.html?src=google&albslr=206250774&isdl=y&aff_short_key=UneMJZVf&source={ifdyn:dyn}{ifpla:pla}{ifdbm:DBM&albch=DID}&src=google&albch=shopping&acnt=494-037-6276&isdl=y&albcp=653151748&albag=36672819047&slnk=&trgt=75384829977&plac=&crea=fr32728997396&netw=g&device=c&mtctp=&gclid=CjwKCAiA8bnUBRA-EiwAc0hZkzZ7AaT8Sf-OAPfjktH9eA2DVeG6_ch84C98iCJVVPi2LbRB8QuSiBoCgrAQAvD_BwE

I guess it will be either today to test BeOS Dano on a VM than on bare metal…


#11

That converter wont work, the disk isn’t the problem per se, but the SATA controller itself. If it’s a desktop you could install a PCI IDE controller, otherwise you’ll need to somehow use a zeta SATA driver or whole kernel with r5 as @damoklas says. No idea how to do that, but would love to hear about it!

EDIT: Also, did you look here: http://littlebluerodent.tripod.com/MIDI/Modern_hardware.htm
This was very useful when I was getting BeOS running in virtualbox. It has some replacement IDE drivers.


#12

To do that you need replace r5 original with zeta kerel+drivers+zbeos (and some server, I think). There was (and still are) even install package for this to update r5. I even made then some hibrid zeta_kernel&drivers+r5+bone+newopengl+newmedia(witholdmidi)+updates_from_openbeos (aka BeOS BONE 5.05).


#13

I was expecting that a motherboard with a Pentium 4 on it would have still an IDE controler onboard, not only a SATA one.
Hence my suggestion to use a converter to use a SATA disk but with the onboard IDE controler. If any, that is.


#14

Oh I see, sorry yes that makes perfect sense!


#15

I was able to get BeOS R5 to sort of work on larger IDE hard drives by using only the first 127GB as basic partitions in the Intel partition table, with the rest past 128GB hidden in the extended partition, not usable by BeOS, but at least it won’t crash on bootup if it’s hidden.


#16

It is (older) motherboard problem, I used 320 GB IDE disk in BeOS.


#17

That sounds alot of complicated and tedious work? in that case it’s maybe better to just use zeta.
But i found out that my bios actually publishes the drives as ide so the problem seems to be the size of the drive, because i booted the iso in qemu and tried to install it to that drive, but beos counldn’t see the whole drive, so i couldn’t reach the partition as it was the last one, and i didn’t
want disturb my whole setup, just to install beos.

Well, it does have 2 of them actually but i don’t any ide drives, and they’re hard to come by.
I’m gonna try to move one of the 2 haiku partitions to that last partition and install beos in there, i don’t have too many options it seems.
I’ll report back how it goes.


#18

You mean you had to hide it explicitly from beos in order to boot?


#19

That’s correct. Don’t remember if it was the BeOS Intel partition handling or the IDE driver that blew up when it tried to access something over 128GB, during boot-up.

Also BeOS R5 can only format up to 60GB as BFS due to a bug in the formatting code (use Dano’s mkbfs to do it).


#20

Not true. I routinely ran a 180GB SCSI drive formatted BFS. If there’s any limitation, it’s in how that crappy ATA interface presents itself to the OS. Oh, and I still have that 180GB drive, and it still boots BeOS 5.03. (I tried it about 2 months ago.)