Little mistake in Haiku Howto Bhyve

I tried to virtualize Haiku on FreeBSD 13.2 Realease with Bhyve. I followed the instruction on Emulating Haiku in Bhyve | Haiku Project. At the end of the HowTo is a little mistake, I think.

If you run: sh -c1 -E -i -I haiku-release-anyboot.iso haiku to boot the VM, the mouse is freezing in Haiku immidiately. Every time I tried.
I had to change the mouse into tablet-mode and then the mouse works fine. For that I changed to command to: sh -c1 -T -E -i -I haiku-release-anyboot.iso haiku
Now I could install Haiku and it runs very fast. Sadly I got no working network connection and I will try this again another day. I’m curious to get Haiku running in Bhyve.

Wanna create a PR for the change at GitHub - haiku/website: The Haiku website. (Pull requests are accepted; please file issues at ?

The guide was written for beta2, a lot of things have evolved on Haiku and I guess that it is the same on Bhyve. It’s even amazing that you only need to add a parameter to make it work.

Yes, I asked in the BSD-Forum for that und got this solution. Another thing is that getting the network up and working is much more complicated. Many more users of Bhyve report about such problems. I give up here and use Haiku in VirtualBox. That runs fast and stable. My FreeBSD ist fast and stable as well and I don’t want to get in problems, only for getting Bhyve running. So I stopped here. Perhaps later on I will give it a new try.
I created a ticket.
I would kill FreeBSD and install again Haiku on my Lapotp. But I wait till we have a really stable browser and mail app.

1 Like