Lazarus 1.9 trunk Qt4 and Qt5 interface (screenshots)

Calling Python (or anything/anyone else) stupid is not the best way to get your point through.

4 Likes

Carp is great btw.

1 Like

Freepascal and lazarus works in Haiku 64 bit now.
Beta the version of the freepascal compiler can already be downloaded from the website of developers.

With small changes of Lazarus it was compiled in Haiku x86_64
Lazarus_x64_in_Haiku

Someone needs these versions in the hpkg format?

5 Likes

Sure go on s40in

Yes, please add it to HaikuPorts so it will turn up in HaikuDepot :slight_smile:

yes…sure …thanks for your effort :sunglasses::sunglasses::+1::+1::+1:

Added lazarus-qt5 2.0.2 and fpc 3.2beta for Haiku 64bit in my 64bit repo

4 Likes

Hi, this is my first post. I installed succesfully lazarus (gcc2) and fpc from the downloaded hpkg. I also installed gdb from depot. Every thing is ok until I try to debug, gdb gives an error: something like cannot attach PID (translating from spanish).

Is it possible to debug from the ide in lazarus? Maybe I need an specific version of GDB?

THX

Perhaps gdb in Haiku 32bit is not fully compatible with Lazarus. Maybe due to the fact that gdb uses gcc2 abi and lazarus uses gcc7 abi.

Need to check gdb in haiku 64bit

It may also be that freepascal is built without GDB support. This happens in test builds. Need to wait for a normal release from official developers

Thanks, we’ll wait for news

I have tried Lazarus debugging in Windows, linux and even in raspbian. Everything was easy installation and debbuging, like a charm.

Unfortunately no success in haiku, it is supposed to compile with debug symbols but even trying to debug manually from dbg complains about lack of debugging simbols in the executable.

As said before, trying to debug from lazarus gives an error from the debugger about impossibility of getting the pid of the application

Actually there are snapshot versions:

ftp://ftp.freepascal.org/pub/fpc/snapshot/v33
- FreePascal 3.3.1:
         - They are developing 64 bit version also.
         - Both 32 & 64 compile OK.
         - IDE do not work correcty because moving mouse is interpreted as code caracters....but using other editor as nano go OK.

The freepascal IDE (fp) uses Free Vision. May be it do not works correctly under Haiku.

https://wiki.freepascal.org/Free_Vision

FPCupDeluxe is able to generate both installations, best than directly from compressed snapshot.

  • Lazarus 2.1.0:

    • Do not work for me, neither compiling from source nor from fpcupdeluxe, it throw me errors (including unable to modify LC_CTYPE locale).

To run FPCupDeluxe (actually V1.6.8e) it need libQt5Pas.so.1
It can be obtained installing fpcupdeluxe under Linux and selecting cross compiling for 32 & 64 it download two dirs with bin & libs (where store libQt5pas.so.1
To run FPCupDeluxe is necesary to open a terminal session modify downloaded FPCupDeluxe permisons with chmod +x and getting together in same directory libQt5pas.so.1 run executable.
Also is necesary to install subversion from depot and QT.

In any case there is working in progress for the next FreePascal/Lazarus versions and it now have the x86_64 target. :grinning:

I have not test to crosscompiling from Windows (64bits) or Linux (64 bits) to Haiku.

1 Like

I have been testing latest release builds of fpcupdeluxe under Haiku 32 bits without a complete functional result, but one of its mantainers show that crosscompiling from win 64 to haiku 64 can generate a functional one.
https://forum.lazarus.freepascal.org/index.php?topic=46898.0
I have not tested because actually i havent a win 64 installed.

Hi,

Currently I am having trouble with crosscompiling from Win64 to Haiku (32 or 64). While in theory it works (simple applications succeed compiling), our company’s app has trouble. Compiling works, but Linking does not. The Linker complains it cannot be started, but actually it has trouble with some components that cannot be linked (TAChart, Indy10, UniqueInstance). It’s very frustrating that I don’t get the correct errors reported because that would make it workable for me, but now I have to quit on this.

So, I decided to try with ‘native’ Lazarus on Haiku: 32 and 64. I fetched them already built from your repo’s, and while the IDE works, the compiler apparantly does not: the IDE, when starting, keeps complaining fpc.cfg is not existing. While actually it does, just not in the folder where fpc itself lives.

Here’s my question: where does Lazarus expect the fpc.cfg file?

Thanks for any pointers anyone might have…

Running it with strace will show you all the file paths where it looks for the cfg:
strace command commad_args

AH thanks for the pointer. Just starting Lazarus from the terminal already does that. Still a lot of output, and I’ve already tried some locations for the config file. A lot of locations are not possible since these days it’s all read-only file system… This read-only stuff is a bitch in my opinion :wink:

Anyhow, nogo yet. I might try checking out the sources again with fpcupdeluxe which runs on Haiku as well, though it seems I have to manuall install svn as that’s not done by default on a fresh Haiku install. And I think svn is not available as a package on 64bit Haiku, which I am testing to at least not get confused wit gcc version and such stuff.
Update, ah goes by full name. Checkout running…

I’ll try a few more things before I quit on this, thanks again!

Svn is available on every supported arch.

yep, as subversion :wink: my bad :slight_smile:

Building fpc 3.2 and 3.3.1 fails with : Identifier not found ‘IsManagedType’.
Very unfortunate. Also on x86 Haiku I get all kinds of for me not so simple faults. Still I’ll try x86 once more later. And I’m on very recent nightlies, Maybe I need to switch back to the official Beta1.

Any pointers anyone?
Thanks!