Issues with R1A4-44702: Intel PRO/Wireless 2200BG, pkgman

I am having a few issues with an old Sony Viao VGN-S360 ( that I inherited from my father. All hardware is 100% operational, I tested it out using XP and a number of third party utilities (Quick Tech Pro, UBCD, etc.) with zero issues.

The only mods done to this machine to date have been maintenance and upgrading. I had to replace the entire fan assembly because the original was slowly coming apart (literally, I lifted it out and the fan fell off). The original hard drive is replaced with an IDE SSD (yes, those do exist, google OWC Mercury Legacy Pro SSD), the RAM was upgraded almost a decade ago with an additional 512MB stick, and the CPU was upgraded about six years ago with a 2.10Ghz Centrino.

The problems I have centre around the wireless and the patch management (so far). So, the bigger issue first: Wireless.

This system has the Intel Pro/Wireless 2200BG, which requires the firmware installer ( Ran the appropriate code, got the stuff installed and… no dice. Nothing. No wireless card recognized. So I rebooted. Went well until all the icons lit up, and then the screen just went… wonky. Like, scan line wonky. Even scan lines shifted left, odd scan lines shifted right. Never completed booting.

I reinstalled (SSD, FTW) and tried looking in the …/firmware/ folder and found the /iprowifi2200/ folder. It contains ipw2200-fw-3.1.tgz which I dutifully expanded. Rebooted again. No strange boot screen this time, but also still no network card.

I am kind of out of ideas at this point. Suggestions?

Second problem deals with patch management. Apparently R1A4 is able to patch itself across the Internet (, but the big issue is that pkgman isn’t recognized as a viable command by the system. In terminal it comes back as:

bash: pkgman: command not found

listdev and ifconfig to be appended once I get them off the unit.

Hi, sorry for the long delay in replying; your post got caught in the spam filter for some reason. R1A4 does not have support for updating itself over the internet, you need a nightly build to do that. And a lot more wireless cards are recognized on the nightly, maybe see if that works?