Issue building Haiku


I wanted to build Haiku from the source, however it always gives me this error:
Populating image …
Extracting src/apps/webpositive/bookmarks/ …
Resolving package dependencies …
Error while writing to file `/myfs/system/packages/noto_sans_cjk_jp-1.004-2-any.hpkg’: No space left on device
Error: Command failed: No space left on device
Error: Command was:
cp -f :generated/download/noto_sans_cjk_jp-1.004-2-any.hpkg /myfs/system/packages

export imagePath="generated/haiku.vmdk"
export isImage="1"
export isVMwareImage="1"
build/scripts/build_haiku_image /boot/home/dev/haiku/generated/haiku.image-init-vars /boot/home/dev/haiku/generated/haiku.image-make-dirs /boot/home/dev/haiku/generated/haiku.image-copy-files /boot/home/dev/haiku/generated/haiku.image-extract-files

...failed BuildHaikuImage1 generated/haiku.vmdk ...
...removing generated/haiku.vmdk

...failed updating 1 target(s)...
...updated 1494 target(s)...

I have tried building with multiple commands. The last one I used was jam -q @vmware-image. I am building this on Haiku, running on VMWare, with 15GB of disk and with just over of 7.5GB free.

Thank you.

This could be a problem, maybe the imagesize should be bumped.

I do not think we use @vmware-image anymore, so the image size may need to be increased. You can use @nightly-raw or @nightly-anyboot instead, which are much more used and tested.

You can use @release-vmware or @nightly-vmware.
I don’t know why @vmware-image is still allowed, it should be removed from the buildsystem and documentation.

Increased the image size from 15 to 20GB, but there are some extra steps I have to take for the guest OS to assume this change. Didn’t understood fully what I had to do.
Tried with @release-vmware and the result is the same.
One more question. If I can build Haiku on Haiku how do I can test it? Can I test it in Haiku? Or do I have to copy it to a USB stick?

You can use qemu but its probably not the fastest.

If you are working on a specific app building its target directly and running it is faster.
You can do the same way with libraries and kits by making a app/ app/lib/ dir and putting the to test lib in lib and the app that uses it in app.
You can test system daemons by using launch_roster to stop them and running your new version (for app_server there is some special casing here, since you can’t stop it at runtime at all without loosing your desktop)

Hope this helps

It is not clear which image you made bigger, but we are talking here about the image the build system generates. The size of that image is defined in the build config files.
If you run Haiku as a virtual machine and you made the virtual partition bigger then you misunderstood us.

I encountered this issue yesterday. In my case the problem was that I was just invoking jam in the repo root which is building some unspecified image. I was doing like so for weeks without problems, but I suspect I had a UserBuildConfig set up (which I forgot about).

This works fine:

jam -q -j2 @nightly-raw

Ideally an error should be shown when build profile is not set correctly.