Into Day 2 of VM install, running into a few problems

Hello everyone, let me start off by saying how refreshing it is to use an OS like Haiku. If it is this good during alpha, I can’t wait to see how good the final release will be! I’m still a little awestruck by the raw speed of this OS, and it is very user-friendly as well. It’s not so much learning how to use Haiku, but more so “un-learning” how to use other operating systems.

Anyway, my experience with Haiku has been near perfect save for the following problems I’ve run into.

-The first problem started near the end of my downloading & installing craze. I unpacked and tried to install KOffice, I remember it asking me if it was okay to overwrite files, or if I wanted to skip it. For some reason I chose overwrite and once it was done installing I tried to open the Kword program…nothing happened. I had the same result with all the other programs in KOffice. I restarted Haiku and thats when the problem started. While Haiku was booting I began to get a ton of error messages that stated “x application encountered an error and Haiku will terminate it and clean it up”. I saved some of the debug output of a few of the messages and closed the rest. Once Haiku is booted, save for WebPositive, I’ll get that same error message whenever I try to close out of a program. All the error messages don’t hinder the ability to use Haiku, but they do tend to get annoying.

Looking back at all the debug output I’ve saved, I noticed the first half of it was exactly the same. Here it is -

runtime_loader: /boot/common/lib/ Could not resolve symbol '_Unwind_Resume_or_Rethrow'
resolve symbol "_Unwind_Resume_or_Rethrow" returned: -2147478780
runtime_loader: /boot/common/lib/ Troubles relocating: Symbol not found
GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

-Another problem is that the sound isn’t working. I’ve tried installing the opensound drivers and removing the older ones, but that didn’t do anything. I’ve tried messing with the VM settings themselves, and it seems like Intel HD Audio “works” (I see the soundwave moving in the music player), whereas ICH AC97 doesn’t do anything at all. Still, the results for both are the same, I still can’t hear anything.

-My screen is 1440x900, but unfortunately Haiku doesn’t automatically detect it. 1280x1024 is what I am using currently, and while it’s not bad, it’s not using my entire screen and I have black bars. I’ve tried installing these Nvidia drivers: ,but I’ve had no luck.

-And my last problem is that I get this error when tryping to open Qupzilla -
"Could not open “qupzilla” (Missing symbol:_ZNK13QWebInspector10metaObjectEv)."
Any idea what that is supposed to mean?

Wow, that is a lot of text! Thank you for taking the time to read through it! I’m hoping my journey with Haiku doesn’t end here, I’d love to eventually make some room on my hdd for Haiku. And who knows, maybe one day Haiku will be all I’ll need.

ThinkFree Office 4

I can confirm all what Diver said.
About Koffice, is true: is from Alpha 2, so will put in your system, incompatible libraries, including an old version of libstdc++ which mess up your system. The better way is to reinstall Haiku from scratch to avoid libraries incompatibility.
About word processing/publishing, i have recently ported Scribus, which is fully compatible with any recent Haiku system:
In anyway i will see if i will be able to port Calligra on Haiku :slight_smile:

-KOffice port is very poor and was made back in Alpha2 I think and I don’t recommend installing it as it installs incompatible libs all over the system.

I guess /boot/common/lib/ is one of these libs, so you can try to remove it.

-AFAIR VMware needs some tweaking to enable sound support: see

ICH AC97 audio controller in VirtualBox works out of the box :slight_smile: A least it does here in Linux Mint 14.

-The nVidia driver you installed is outdated and the newer version is already included in Haiku.
But since you’re running Haiku in an emulator you can only use VESA anyway.

If you’re using VirtualBox you can add a custom VESA resolution by issuing VBoxManage setextradata “VM name” “CustomVideoMode1” “1600x900x32” in your host system. Not sure about VMware, though.

-Qupzilla error has nothing to do with Haiku. Most likely you’re either using incompatible version of Qt or Qupzilla itself. Try to install both from this page

Anyway, since your install is quite messy by now I recommend to install a nightly image from here to avoid other possible errors.

Thank you for the advice everyone! And Diver, thanks for linking me to the nightly builds, I installed the latest one and my sound is working! And I’ll try that trick with VirtualBox to change the resolution. To be honest I’m not entirely sure what you are talking about, but I’m sure once I poke around with VB I’ll figure it out. :slight_smile:

Giova, thank you for porting Scribus! I saw it on Haikuware the other day and it seems to be working just fine. I’ll also give ThinkFree Office a shot, thank you kim for linking it.

So far I’m loving Haiku, I’m hoping I’ll be able to contribute to the project in some way once I’ve spent more time with it.