Intel_extreme "Fix"

Several months ago now, I installed Haiku on a small partition on my laptop and immediately had issues with the Intel_extreme video driver. Some helpful folks here pointed me toward a means to default to the VESA driver, and while it fixed my display issues it also locked me into a much lower resolution than my native.

Due to this, I kind of put my Haiku use on the back burner for a while and haven’t done much with it since. However, I got the itch again and decided to try a fresh install of the most recently nightly.

I flashed the anyboot ISO to a USB drive and booted to it with the predictable outcome: my display was all messed up again. The best way I can describe what it looked like is if you took every element on the screen and stretched it across two renderings. I’d see, for instance, the Home icon, then a stretched out bit about an inch wide, then the Home icon again, all while blinking and looking very much unsuable under Intel_extreme.

On a whim, though, I stumbled into a fix, and I must say it has me feeling quite foolish for not thinking of it earlier: increase the default Refresh Rate from 60 to 70. That’s all. I ran as a Live CD, went into Screen preferences, and upped the Refresh Rate and everything was fine.

Now I can run Haiku normally with native resolution and look forward to fully exploring the OS as it was meant to be. Hopefully, this will help others who might still be having issues with Intel_extreme graphics.


related question: I’m seeing in the Screen preferences the following info:
LG E2241 21.5"
Intel GMA (i945G)
(102 dpi)

I also set the refresh rate to 70Hz and it works.

However, only the color depth of 16 bits/pixel works correctly.

If I try to set the color depth to 32 bits/pixel, I get a strange horizontal bar of about 70 pixels of static:

Any advice??

1 Like