Installing Pre-Software


#1

Trying to install Jam with “sudo ./jam0 install” but ham command not found. Already cloned git repository for haiku (git clone https://review.haiku-os.org/haiku) and buildtools repository ( git clone https://review.haiku-os.org/buildtools). Any suggestions?


#2

jam0 should be in buildtools/jam/


#3

Hi jjpx, I just cd to buildtools/jam and ran the same sudo command, but got the same error message. I already “ls” all the items and there are no files named jam0


#4

What operating system are you running this on?

Haiku itself doesn’t have sudo if you are attempting to build on Haiku, and you can omit it if you already have a root shell. Also Haiku already has jam installed so you don’t need to build it.

Also if buildtools/jam doesn’t contain jam0 you didn’t run make first before running ls… once you do that it will be there and you can continue.


#5

I have macOS High Sierra Version 10.13.6. I ran make and now it works. Thanks


#6

No problem have fun!


#7

Nice little chicken and egg bootstrapping conundrum. To build a build system, you must first build the build system with a different build system.


#8

At least the Makefile is relatively trivial… for jam0

It’s really not that big of a deal.


#9

The process is confusing because:

  • It’s undocumented (sigh)
  • You have to first run make, then jam0, then jam0 install, which is unusual.

#10

Write the documentation to https://review.haiku-os.org/buildtools?!