Installing new software in VMWare, internet connectivity?

Hi there,
This evening I downloaded a copy of the Haiku image for VMWare, which boots nicely, and runs brilliantly. However, I’m unable after much tinkering to access t’internet, I’ve tried putting the Ethernet option in VMWare as Bridged and NAT, and have received no joy. In both configurations, DHCP picks up an address, but it’s useless, and I get no DNS.

Does anybody know how I might go about setting up a proper internet connection within VMWare, so I can then install a web browser etc?

Oh, and by the way - the laptop is connected to my wireless LAN, and NAT Mode has worked in other virtual OSes I’ve used today. This is specifically a Haiku issue.

Oh, and even more by the way - Haiku looks a hell of a lot better than I was anticipating, nice one! :slight_smile:

Regards, Matt Stevenson.

Can noone help me atall?

I have the same results, I chose for it to have a NIC through VMware but by going into the terminal “ifconfig” there’s nothing there. Somewhat disappointed but have a feeling it’s based on the image and not a real install?

Worth having a go at installing myself, using Virtual PC, do you reckon?

I have had no problems with vmware (granted, I haven’t tried in a while).

Make sure you change the vmx file to use the e1000 emulation (utilizes the ipro1000 driver in Haiku). this provides a much better experience than the default “vlance” driver.

Also, depending on your network setup, you may have better luck running vmware in NAT mode vs. Bridged mode. Maybe switch 'em and see what happens.

Last I heard, Virtual PC wasn’t much fun trying to setup.

Ok, well my VMX file contains the following, which I believe to be what you’re getting at:

ethernet0.present= "true"
ethernet0.startConnected = "true"
ethernet0.virtualDev = "e1000"
ethernet0.connectionType = “nat”

That’s configured workably, right?

And by the way - Virtual PC is surprisingly nice to set up, I’ve got a couple of VMs running in it, that I set up myself from the installer CDs. It is good.

Funny, I just switched to VMWare Player 2.0 just because I couldn’t get net to work in QEMU. I just used bridged when installing VMWare and the haiku.vmx config linked below (changed to 768MB though) and it works out of the box for me.

Nope, no joy.
I’m getting an IP address, but I can’t ping successfully, and there’s no web browser to try browsing with anyway.


Can you ping your router’s IP or maybe another known IP such as (

I added a new topic “Networking notworking under vmware” yesterday (March 22), before I read this topic. I think you are having the same problems I am having. I figured out that what is happening is that DHCP is failing and the address you are “getting” is just a default. You can read my topic to see how I got around it.