Installing Haiku on Acer Aspire One - internet issues

Hey guys

I’ve been looking around and can’t seem to find any solution for my Acer Aspire One. I am trying to install Haiku through my external dvd writer/player, but I keep getting the same message during boot:

“PANIC: did not find any boot partitions.”

I’ve allready tried to disable DMA and run safe mode. I’ve tried running GParted and fdisk through it and create a BeFS partition. Still the same problem. Any solutions?

Does it boot from the CD into live mode?

If so try this:

Might need to put the Haiku bootloader on the drive like I did.

When the CD starts to boot, hit the space bar until it gives you a menu to choose which media you want to boot from, choose the HD and boot. Assuming it boots then you can load the Haiku Bootloader and reboot to try again.

You will have to file a ticket with “bt” output attached, plus Haiku revision and issue that occurred.

This kinda sounds somewhat similar to your issue.

You should also search tickets for similar issue and file your own if not listed:

Your only other option is to install from USB key since DMA & SAFE MODE failed for you. dd Haiku to USB key, boot & install from there. You can also create partition & dd Haiku image to it but partition space used will be limited by size of image (wasteful).

I have a Aspire one 110 and no problem with Haiku when installing from USB stick.
I even have Wlan (no security though)

How did you set up the Wlan? What does the network prefrences say?

Okay I’m posting in this thread since my other thread is being weird.

Here is what i got from listdev and ls /dev/net

device Network controller (Ethernet controller) [2|0|0]
vendor 10ec: Realtek Semiconductor Co., Ltd.
device 8136: RTL8101E/RTL8102E PCI Express Fast Ethernet controller

device Network controller (Ethernet controller) [2|0|0]
vendor 168c: Atheros Communications Inc.
device 001c: AR5001 Wireless Network Adapter

ls /dev/net

So here you go guys, what is up with my internet? I seem to get a green light with wired net, but can only ping local hosts, no sites.

Appears you have wired networking from /dev/net. Does it show and can you configure it in network preferences? Try static and dhcp.

Ping your router’s IP. If it pings then you have either DNS or route issue. If you can’t ping router than you have driver issue. Gigabit router?

The rtl81xx driver is close to 16 months old. A developer is looking to update this driver in about 1 week’s time which may help. For now, you can try what I wrote above which may help fix your issue.

I’ve tried both static and dhcp.

I can ping my router without problems, and I’m not sure if it’s a gigabit router. Everything works fine on my Windows computer, so I guess the problem lies in Haiku.

did you set the gateway and dns server ip addresses (should match Windows)

in my case my gateway is, and my router supplies dns on and

Both must use dhcp (think I read about some one having problem if not both was the same)

wlan will connect to the first open network don’t know if the wlan config tool are ready.

if you take the latest from svn there can be that something don’t work as it should, last time i tested wlan was before it was integrated in to Haiku svn.

Well the WiFi card doesn’t even show in prefrences. It’s allready set to DHCP…

Provide Haiku revision number that you have installed on your system so I can tell what version you have.

I am pretty sure the wireless has to show up somewhere under /dev ( I would think in /dev/net ). Since it does not show in preferences, this confirms the driver is likely not loading or not present.

WiFi was included in Haiku in late December. Not part of the Alpha1 release. Use a recent nightly to check for WiFi. You may want to wait for the rtl81xx driver to be updated too.

You can follow changes to Haiku here:

I seem to have Haiku R1/alpha1 (Revision 33109). Installed about a week ago.

R1 Alpha1 is too old and does not include WiFi support. You can download & install it yourself from here:

Another option is to install a Nightly Image ( sometimes come with bugs ) from here:

r34990 seems to work good and already includes WiFi drivers but no WEP or WPA.

In this case, the wifi driver is not included. It can be obtained at . The rtl8136 should work, but not with DHCP. One needs to set the ip, gatewqay, and DNS servers.

Using DD to copy a Haiku-OS image to a SD card, I find that I can use the SD card to boot most Netbooks out there.

In the BIOS the SD card will show up as a bootable drive if the BIOS supports it, so far the only modern machine it does not work on is that NetBook from the phone company.

Well I downloaded a new nightly and installed it, and the wifi card shows up in network prefrences, but still internet :frowning: Can only ping local adresses.

Okay guys, I got wired net working, but WiFi still not working.