Installation problem

Hey all,
I tried to put Haiku on a new system and it doesn’t even get as far as the screen with the icons. The screen just goes black after the initial series of dots. This much is normal, but the loader/icon screen usually appear shortly after that and on this computer there’s just nothing, so there’s not much to go on. Tried holding the safe mode key (thinking it was a problem with the monitor) but still nothing shows up. Any idea what’s causing this or should I just go straight to trying to install from USB?

[quote=24bit]are you using a AMD box may be?
My Athlon64 X2 does exactly what you are describing, a known issue.[/quote]
Since similar chipsets may behave differently, and some Intel processors lead to the same problem, it’s rather a Haiku incompatibility with some BIOS implementations.

Changing boot medias (USB/HDD/CD) doesn’t improve anything.

see ticket #4408 and related.

AMD chipset ? if so which one, there is a amd chipset ticket in trac.

are you using a AMD box may be?
My Athlon64 X2 does exactly what you are describing, a known issue.
Best wishes!

Thanks for the help; I think that it was an AMD problem, since I just tried another computer and it worked almost flawlessly. This system and another system I failed to get Haiku running on were both HPs; something about HP BIOS, maybe?

Sorry, I don’t know the exact chipset, I was installing Haiku for a friend and gave the computer back when it didn’t work, and forgot to check.

Its definitely an AMD problem. Haiku reboots my Duron based system before it gets to the icons.I can run BeOS Max on it because Vassilis Pernatzakis changed the kernel to allow the different HLT instruction set, I think. Anyway he made a patch to fix the AMD Duron,Athlon problem. Maybe the Haiku community could get ahold of him and have him fix Haiku so it would work with AMD mobo’s.