Installation failure on Probook

Hello. I had installed a copy of Haiku R1/beta3 on my Acer, and I liked it so much, I decided to install it on an HP ProBook 650 that was lying around. I followed the same steps which worked on the Acer - I wrote the ISO to a USB with Rufus, then booted the HP from that USB drive. The Haiku boot splash screen came up okay, and all the icons (including the rocket) activated. Then the screen went black. I waited a half-hour, but nothing ever occurred. The screen stayed black and the computer seemed frozen. So I then restarted the HP, and tried a few more times. Still nothing. I tried to go into safe mode and also disabled addons, but the installer never loaded after the splash screen disappeared. It seemed that since all the icons activated easily, the installer screen should as well. So I finally gave up.

My configuration is:
HP ProBook 650
BIOS Version: L78 Version 01.40
Processor Type: i7-4800MQ CPU
and 8,192 MB of RAM

Also, a (barely used) copy of Windows 10 is on the hard drive.

Did you try “fail-safe video mode”?

You might also try a nightly build, these have a lot of fixed bugs compared to the nightly, already.

Thank you for the assistance. I entered “fail-safe video mode”. Everything came up as it should. I proceeded to install Haiku (not a nightly build, the same Beta3) onto the hard drive.
However, when I tried to boot for the first time, something went wrong. Haiku did not appear. Instead, the BIOS gave me this message:

BootDevice Not Found
Please install an operating system on your hard disk.

Hard Disk - (3F0)
F2 System Diagnostics
For more information, please visit:\go\techcenter\startup

Confused, I reinstalled Haiku on the hard drive. The same error occurred. So I finally went to the website mentioned in the error. It was not very helpful, saying that perhaps my Optane memory was bad. I have no Optane memory.

There was one thing about the installer which seemed odd to me. After the installer completed, and before I closed it, I clicked on the tools menu in order to install a Haiku boot menu on the hard drive which was successful with the Acer. However, I was unable to install a boot menu, The program said that the drive was “incompatible”, so that step was skipped. Could the missing boot menu have caused this or something else?

Probably you are on a GPT/EFI system. In that case, you have to partition the drive somewhat differently and manually install the EFI loader. There is a brief guide on how to do that: UEFI Booting Haiku | Haiku Project