Install on a Promise FastTrak 100 TX2 ATA/RAID controller

Hi everyone, I was wondering if anyone could help me install Haiku on an old PC that I have. This PC is a Pentium III 700 with a 440BX chipset, so the IDE controller supports ATA-33 only, which is painfully slow to run Haiku (believe me I’ve tried). I’ve tried to fix this by buying a Promise FastTrak 100 TX2 ATA/RAID controller which supports ATA-100, but when I try to install Haiku, the LiveCD boots fine but when I have to partition my disk via Drivesetup, my HD is nowhere to be found. I’ve thought that Haiku supported my controller and it does:
So I’m absolutely clueless about this issue, maybe it doesn’t support the installation but it does support access to a drive attached to the controller, but when I boot Haiku it only mounts its own partition (the CD one), not the others that I have on the HD (Linux installation).
Thanks in advance!

promise_tx2 add-on is not included in HaikuImage

It was removed from the build in
and as commit message says it doesn’t compile now

You can try filing a ticket at

Thanks Diver for all your help!
As per your suggestion I’ve filed a bug:
I’ll cross my fingers hoping it gets fixed (but I know there are things much more important)