Instaler can't initialice Be filesisten

I spent a week triying everything I could imagine to install Haiku on my test machine. First with the cd and next using dd to copy the raw image to the hd butt the problem is always the same. The drivesetup program identifies de hd but cant do any modifcation to it, only delete partitions, it cant create new parttions neither it can initialize the BeFS so the instaler sais that the isent any suitable partitions to install.
When trying to initialize BeFS the drivesetup program sais tha it cant initialize de BeFs in the partition “”.
I tried creating the partiotions with varios partition programs, partition magic, paragon, acronis, fdisk…
but the error persists.
Mi test machine is a PII 450 with 196 MB sdram 4Gb hd am ati Ragepro 8MB agp, Creative (ensoniq ES1371) sound card and an realtek rtl 8139d network card.The mainboard is an Asus P2B (440 BX).

Sorry for the long explanation, and for mi bad english. I wish someone can help me a bit.
And well, I already tied every safe option on the boot menu but nothing better only eslower loading time. and the live Cd works perfectly if I go to the descktop.

Thanks in advance for any help.

Drivesetup is not finished yet. Requires using another program on Windows or Linux to create partitions.

Delete and create partition using Gparted LiveCD.

Format the partition to fat32 or try unformatted with Gparted. Use Haiku Installer to initialize to BFS.

Install Guide:

I would think you are using pata drive. What size is the drive? If you cannot get it to work with above then give partition layout info.

Partition #, file system, partition size, primary or extended

Partition1, FAT32, 10 GB, primary
Partition2, EXT2, 12 GB, primary
Partition3, 48 GB, extended
Partition4, XFS, 48 GB, extended


Yes, is a PATA drive, 4113 MB, I think it’s enought to install Haiku on it, and I will use this system only for Haiku because i think this is the best OS for a system with only 196mb of ram and an old cpu like the PII.
I already tried Gpartet, and oder partition programs like I said in the first post, and also tried leaving the new partition unformated, and also tried by seting the partition tipe to beos (0xeb) if my memory doesn’t fails, but nothing, the instaler cant initialize the BeFS, it’s like it can’t se the partition but only aat the moment of initialiciong the fs, because drive setup shows the partition but can intialice the fs. Last night I instaled a copy of BeOS 5.05 withought any trouble, only it took much time to finish the instalation, more than an hour. Only I saw one thin extrange when instaling beos, at one moment the drive setup said something about an inixistent partition in the SCSI disk. The motherboard Bios has an option caled, SYMBIOS that has somethinf to do with the SCSI controlers, maibe the problem its related with that??I dont have any SCSI controler instaled,in sure of that because I mounted the system with spare parts just to tri Haiku on a real system, because using the Os on a virtual machine thoes not make the system realy usable…¿?¿?¿?

Thanks for the patience, Im impatient to know the reason of this bug jej

yes, 4 GB is enough space for Haiku. Haiku Alpha uses around 600 MB to install.

yes, Haiku ( or even BeOS ) are better choices for a system with low RAM & older CPU like that one.

Non-existant partition? Something not right with your partitioning. If your BIOS has SCSI options, turn them off. Haiku does not support SCSI devices and may cause issues.

Only things I can suggest are to turn off SCSI in BIOS. Re-partition the entire drive from the start ( delete all partitions and go through Gparted to create 1 ( or more ) partitions ). Non-existant partition sounds like partitioning issue.

The Hd is IDE but I noticed that BeOS shows it as “/dev/scsi/0/0/raw” its a unformated partition of course, I wiped the entire HD (zero fill) and created a new primary partition, an disabled the “SYMBIOS” option in system BIOS.I think that the HD driver recognices the HD as an SCSI drive because of the System BIOS that may have a bug on it or something, so I think that I’ll can’t install Haiku on that system until Haiku supports SCSI or until the problem with the HD recognition is solved, buaaa It’s a shame, I only have that system to test at home :(:(:frowning:

Every way, thanks for the help :):slight_smile:

Anybody knows if there is a partitioning aplication that fully support the BeFS, so tyhat I can create the partition a format it outside the instaler??? I tried creating the partitions with the Beos 5.05 live cd but still no luuk:( the instaler keep saying that the are no suitable partitions to install the OS. :frowning:

Only BeOS and Zeta can create partitions and initialize them to Be file system.

Something is not right with your computer setup. BeOS should be able to create a partition on a PATA drive. You should really look over your configuration. It has to be disk related.

Start with your BIOS & go through ide/disk options ( turn off dma in BIOS ). Turn off any scsi options. Next pull out the hard drive. Check the jumpers on it. Jumper it for master and connect it as ide0 master. Make sure you do not put the ide cable on backwards. Delete & re-partition the drive. Try installing again.

Something is not right with your setup which is giving BeOS & Haiku trouble - Linux is able to workaround the issue.

I have installed BeOS to 6, 10, 30 and 80 GB hard drives.

Well the trouble is width the Haiku instaler, like I said a few coments above I instaled Beos 5.05 on this machine whit no problems only that estrange thin that Beos displayed the HD as /dev/scsi/0/0… And I instaled on this system various Os’s Win 98se, win xp, puppy linux, dam small linux, ubuntu 7.10 and debian, and its the first time I found this isue. The bios has this Symbios firmware that it’s used to support scsi cards from asus, that’s what I’ve read in the manual, and the problem seems to be that Haiku missunderstands the bios info and think that the hd is scsi. And well, I been using computer hardware since my first Atari 64 XE, and when I studied computer hardware maintenance My grade was 10 Over 10. Nobody is perfect, butt thinks like putting the ide cable backwards well no and nowadays almoust every cable has the key so that it’s imposible to put it backwards, it’s not like in the XT and AT days jaj;) everything it’s posible butt I already checked thins like that :slight_smile: jej

Thanks aniway, I always apreciate the people who want’s to help :slight_smile:

I have Acronis Disk Director Suite version 10.0 (build 2,089) it will let you set the type of partition to BeOS, 0EBh, not sure what it is.

thanks, I already tried Acronis with that option, butt the problem is that some OSs think that mi HD is an SCSI drive, last night I instaled ReactOS with no problems and it reported the IDE controler as an SCSI controler, and later I instaled Puppy linux and it also reported the HD as dev/sda1, I don’t nknow why butt some OSs have this problem with this motherboard. Well the Asus P2b is a great MB whidth support for ECC 72 wide SDRAM and thins like that butt i think that until Haiku supports SCSI or it identifies correctly the IDE controler I’ll can’t use this OS.

Installs nicely on pentium II gateway g6-350 - runs fast. Uses 60MB of the 196 ram. But sound Ensonsiq ES1371 does not work. It is built into the Intel motherboard. MB440BX
am trying Haiku since puppy and Antix won’t install.

Try one of the sound drivers from the BeBits website:
If that one dosnt work try other ones on this page:
I’d bet your old card is a “soundblaster compatible” so you might try something along those lines.

[quote=Snuhwolf]Try one of the sound drivers from the BeBits website:
If that one dosnt work try other ones on this page:
I’d bet your old card is a “soundblaster compatible” so you might try something along those lines.[/quote]

The first link is to an obsolete driver for the wrong version of the wrong OS, and the wrong chipset.

The ES1371 was once sold by Creative (as were many other chips) using their Soundblaster brand but they aren’t Soundblaster compatible in any sense that’s relevant to obtaining a working Haiku driver.

There is probably an OSS driver for this chip which is available for Haiku, sadly Haiku’s PCI subsystem and the hardware resource management in general remain half-finished, which is one reason why so many users still have problems getting it to work out of the box.

thanks -
maybe no haiku for me either