IDE/ATA on older hardware 440BX

Hi all,
I thought it would be fun to bring BEOS back to my ABIT BP6 (440BX chipset) as I ran it back in the day many years ago so I have been trying to get the latest Haiku nightly on it (installed). Runs from USB quite well.
Let’s just say I’ve proved there is an issue another poster found on here - it appears the IDE/ATA driver changed somewhere in R3 to R4 and that rules us old IDE users out of the running. I get constant ATA errors in syslog after booting Haiku anyboot from USB (using PLOP CD). Can’t use the CD drive or HDD on IDE bus. Tried all sorts of things, HPT66 IDE won’t work, an Sil IDE PCI card won’t work. I don’t have a SATA bus or card to use unfortunatly.
I’ve tried some old R3 nightlies but came across other issues naturally failing to boot on USB completely.
If there is no suggestion from anyone that can help acheive this my last hope is installing to a USB disk or buy a SATA card (nup).

Strange, I have been able to boot nightly builds off of IDE drives on several old motherboars here without much trouble… Not sure if I have any with the 440bx chipset to experiment with but there might be a board hiding in the piles around here somewhere.

Thanks Wildman for the response. I found the other thread that talks about a similar issue (2014). Your actually in it too!
I agree with you that it should work. I was fascinated this was the showstopper. I’ve even set up VBox sessions (on main modern PC) with virtual IDE and it works there fine. You would think it could be a hardware fault here but I can tell you Linux/WindowsXP booting and running from the same IDE headers, same cables, same drive even.

IIRC this is a known issue with some older IDE hardware. It happened when they switched from the old IDE stack to the newer ATA one. One way to fix it is to build a version of haiku with the old IDE stack.

However, the best thing to do is raise a bug and hopefully the ATA stack can be fixed. I’m not sure if there’s a relevant ticket already. Maybe you should add a comment to one of these:


I tried Haiku on the same hardware and created a ticket for this already:

My solution is that I disabled DMA using the boot menu. Haiku boots then without issues, albeit slow.

Strangely the DMA disable option didn’t work at all for me no matter what.
I’m curious to find a nightly that used to work just to confirm it’s not something “else”. I’ll look through those bug reports.
I won’t be building my own build of Haiku, I’m not that serious. If IDE/ATA doesn’t work and there is no trick to getting it to work, I’ll try USB or some other trick.

Interesting… I just checked one of the older boards I was running early hrev48000 builds on, and it has the Intel 440BX chipset…

I also have two old boxes with BX440 here, one Asus P2B-S and the Abit Dual Celeron BP6. I only have issues with the BP6 and DMA. The Asus does not have any issues. So it seems that this issue may be related to something special on the BP6.
I could do more tests if someone wants to delve into this, but so far no one volunteered…

Hi there thanks for confirming the BP6 issue/anomaly. I won’t ask you to persue testing unless you are curious yourself. I was only curious if there was some simple option/fix or alternative module to get me progressing. I’ve had to move on other OS on it for some fun. Other DEs under Linux of all things. I ran it for work for a day the other week just for fun, pretty amazing.