How to make bootloader remember "safe mode" selection? (solved)

I’ve just installed Haiku on my laptop. It runs perfectly except video (Intel GMA X3100). Setting “Safe video mode” in boot options helps, but doing this every boot is annoying.
Is it possible to configure boot parameters or something?

1 Like

Hi Eugene!

Unfortunately Haiku doesn’t remember safe mode selections. Here’s something you could try:
You want to start Haiku in VESA mode instead of it unsuccessfully using the intel driver. I assume at least, that it tries the intel extreme driver.
So, boot up in safe mode, do a query for “extreme”. Select all 3 files/links. Invoke Zip-O-Matic add-on to make a backup on the Desktop. Now delete all “intel extreme” files.

My reasoning is, that now Haiku doesn’t find an intel driver, it will use VESA by default.



Yes, this works.

Removing problem drivers works as you expected.
Thanks, Humdinger.

This trick still works in Alpha 4.1

But how to do it in a nightly build? That system directory is locked up tight. Is there some kind of sudo command to use?

You can add fail_safe_video_mode true to the kernel config file.

I haven’t used it yet but the EntryBlacklist setting described in the commit message of hrev46391 sounds like it would allow you to prevent a troublesome driver, add-on, etc from being “extracted” from a particular package on each boot.

Thanks, that worked.

Maybe there’s room for an advanced setting in the Screen Preference there.

See discussion about that here