How to get Haiku running in VirtualBox?

yeah… i mean windows version of virtualbox. i found some japanese site decribing how to do it - but it referenced to mac os x virtualbox version. it used the tool named vditool to convert raw haiku image to virtualbox image. this tool is not available under windows. anyone knows how to run haiku in virtualbox running on windows? many thanks!


I’ve the same problem but I’m running linux.
I tried to run the two toold suggested on the jap site, but they failed (I should still ask vbox devels about this).

but: what’s the iso I need to properly run haiku?


I have tryed (without success) to run Haiku with VirtualBox (on an Ubuntu 7.04). Each time, I can see the Haiku logo and after maybe 2s I enter the kernel debugland.

Is there a way I can send you debuging informations from thoses attempts ? Has someone succeeded in making Haiku to boot in VirtualBox ?

I know nothing about VirtualBox - but it should support some type of serial output to a text file.

You’ll want to redirect COM1/Serial1 to a text file, and post that in a bug report once you have it.

Some things you can try to get Haiku to boot would maybe be disabling certain hardware - like the network or sound emulation… sometimes the ne2k driver in Haiku (etherpci) crashes - such as on Parallels.

vditool IS available for win32 here:

Put the exe in the virtualbox directory (because it needs some dlls)
Anyway, i couldnt boot Haiku. It crashed.

anyway - thanks for your info! some day it will boot for sure… :slight_smile:

I have posted a thread on VirtualBox forum in order to know how to listen on a virtual serial port. I will let you know.

As described in VBox documentation, I have set options to connect Haiku virtual machine on a Unix Socket «/tmp/haikuPipe». I used the socat utility to transfer output to a file

socat -x -d -d -d UNIX-LISTEN:/tmp/haikuPipe CREATE:~/Desktop/output

and launched Haiku. I did enter kernel debugging land without a byte sent to my socket :o(

Is there a way to dump something useful from the debugger ?

run bt which will return a backtrace (or sc works also)

You can also dump out the threads and teams by using threads and teams

Here it is :

PANIC: release_spinlock: attempt to release lock 0x800a6820 with interrupts enabled

Welcome to Kernel Debugging Land…
Running on CPU 0
kdebug> bt
stack trace for thread 0x1 "idle thread 1"
kernel stack: 0x80101000 to 0x80104000
frame caller :function + offset
80103e1c (+ 52) 8007b6e8 :invoke_command + 0x0074
80103e50 (+ 48) 8007b806 :kernel_debugger_loop + 0x00de
80103e80 (+ 32) 8007c286 :kernel_debugger + 0x00b2
80103ea0 (+ 192) 8007c1c9 :panic + 0x0029
80103f60 (+ 48) 8002ff3f :release_spinlock + 0x0067
80103f90 (+ 64) 8002d2e9 :scheduler_start + 0x002d
80103fd0 (+ 32) 80029211 :start + 0x0409

You will probably want to capture the ENTIRE log and create a Trac ticket explaining the problem.

Then one of the developers will likely see it and try to identify what causes it.

Also remember to specify what revision of Haiku you’re using.

There is a Trac ticket already opened for this issue:

i got r22861, the problem still there, anyone do something? and was vbox-1.5.2.

How did you manage to get output using socat?

To convert a Raw disk image to the VirtualBox VDI format:


Easy, and VBoxManage is included with VirtualBox 2+ :wink:

vditool is no more. If you are trying to convert an image use VBoxManage.

VBoxManage convertdd ~/Downloads/haiku-alpha.image ~/haiku.vdi

Haiku doesn’t (to my understanding) run at all under virtualbox since virtualbox requires a kernel-space component (linux/windows kernel). It is a fork of the qemu emulator. In linux you can easily run Haiku under qemu virtual machine as long as you disable the kernel space component (kqemu) if your distro loads the kqemu module at boot.

qemu -no-kqemu -hda haiku.image

should work. To get networking also: ‘qemu -no-kqemu -hda haiku.image -net nic -net user’

qemu crashes the same way when trying to use the kernel space component.
It’s a bit slower without kqemu but it works.

qemu has also the advantage that it can boot raw harddrive images and you don’t need to convert the downloaded/compiled images to .vdi

Haiku has worked just fine in VirtualBox for quite some time for me. In fact, i have been compiling under Cygwin and using VirtualBox to test the images.

But the thing is: You need to enable VT-x/AMD-V emulation. Otherwise it wont boot.

Settings -> General -> Advanced -> tick Enable VT-x/AMD-V


Oh, and if your PC doesn’t support this you might just be out of luck :(. For now at least, anyway.

I just downloaded VirtualBox last night, Haiku was the first OS I tried and it works flawlessly. I did not even need to change any setting or anything like that. All I had to do was use ‘VBoxManage convertdd’ to change the raw image to ‘.vdi’ image.

I’m running Mac OS X (Leopard) and VirtualBox 2.0.4.

The performance is pretty good too.

Your understanding is flawed :slight_smile:

The “kernel component” you are speaking of refers to the host OS, not the guest.

There have been issues with Haiku running in both VBox and kqemu in the past, but this was not because of something missing from Haiku - rather it was due to the design of Haiku causing unpredictable behavior when running in these VMs. I’m pretty certain the VBox issue is resolved (or has been worked around) - not sure about kqemu.