Has anyone successfully compiled Haiku on a Mac?

Has anyone successfully compiled Haiku on a Mac? Before I tried compiling on a Mac Mini, I first tried installing from a USB flash drive and then from a DVD. As expected, installing from the USB flash drive was not successful. Installing from the DVD was not successful either.

When compiling, I received the below error message:

make: *** [cross] Error 2
ERROR: Building gcc failed.

I’m not sure whether Haiku won’t compile on the particular model of computer that I have been trying to install Haiku on, or whether I have been incorrectly performing the steps for the compile-method of installation.

Check this article https://www.haiku-os.org/articles/2012-05-08_building_haiku_mac_os_x_106_or_107_homebrew

Thank you, Diver. I plan to take a look at it.

I tried installing homebrew but was unable to do so successfully.

I had previously compiled on a MacBook, and then tried to build on the Mac Mini. That was also not successful.

I have now also tried compiling with GCC4 on the Mac Mini, but I was then unable to build Haiku successfully. When I had previously tried compiling on the Mac Mini, I had used GCC2.