Hardware Not Found


#1

Tried to run Haiku from USB flash. Booted to the desktop fine, but very little worked. No sound, no networking, no keyboard. The mouse worked but I really couldn’t fix much without a keyboard.

Is Haiku picky about hardware? Running this on a fairly modern system over Windows 10 Pro 64-bit.


#2

Not in general, no.
Would you mind coming up with a bit more sensible title for this thread? And maybe a bit more meat that people can respond to. :slight_smile:


#3

Well, each device will need to be investigated one by one.
We will need:

  • The syslog from /var/log/syslog
  • The output of listusb (or lsusb running Linux on the same machine)
  • The HID descriptor for your keyboard if it’s USB (it’s located in /tmp)
  • The output of listdev (or lspci running on the same machine, with flags to show the numeric PCI IDs)

When keyboard doesn’t work, you can use the keymap preferences as a cheap on-screen keyboard (type something in the test area, then copy-paste to terminal, or drag and drop keys to terminal). It’s quite painful, but we have to start with something.


#5

Windows 10 64bit doesn’t mean much. Windows 10 will run on a wide variety of hardware. What exact hardware are you running? Every hardware has different compatibility, even between revisions of the same hardware. Perhaps if keyboard isn’t working in Haiku to find out natively, use Windows to tell you the names and chipsets of the devices. The more info the better.

Also, I’ll go on a limb and assume a USB key board is being used. Have you tried other USB ports? Perhaps a USB 2 port?


#6

Did you try a nightly build or the beta release?

A number of newer ethernet cards (e.g. Intel Gigabit) weren’t supported on the beta, but changes to support them have been merged since then. So, you may want to try with a nightly.

Sound is a known issue right now; there’s some long-standing issue in the HDA driver that hasn’t been solved yet.