Hard disk Haiku boot problem

Hi guys,

After some tries, I was able to get the “Haiku” entry on my grub to boot…but now all it does is display a black screen with colored bars (kinda like the color bars on TV).

The “colored bars” are on the top-left of the screen. There is HD I/O for a few seconds and then nothing. Is this due to my monitor not being supported? I have an old Samtron 14" monitor whose maximum resolution is 800x600. I used to have troubles with this monitor when trying to run old linux distros, so…

Also, do we press F8 at startup for boot options?
Is there something I can do about this issue?

NB: I dd’ied an image I downloaded to a spare partition and then I ran makebootable on it. Everything seems to be perfect except for this.

The colored bars you see represent Haiku’s boot splash which is probably unable to display with the proper color depth/resolution on your hardware. I have seen it a couple times when messing with older chipsets.

Likely the EDID info coming from your monitor is ancient :slight_smile: (also, if you have a somewhat older video chipset that doesn’t have much video ram, I’ve seen that cause similar issues).

Hit spacebar after selecting Haiku from grub to get the Haiku boot menu.

Hi vishy,

I’m not sure what’s wrong, I guess it’s the graphics card, you enter the boot menu by pressing the space bar right after grub has started Haiku.
You can try various safe boot options, particularly the safe video mode.

Good luck!

Thanks for the reply guys…

I tried all the safe mode options in the Haiku Boot menu, but at the most it just drops me to GDB and then when I quit it, it drops me to the kernel debugger. I will try it on an other hardware tommorow, but I was really hoping to give this aging hardware a new lease of life(its my main system you see)…

Anyways, if you guys think of some thing please tell me, and if you need me to post extra details then I will do that too. Hmm…I the kernel debugger, it said “Double Fault” or something. This reminds me of when GNU/Linux wouldn’t boot on my hardware!

You should probably open a Trac ticket with a full hardware description and your experience.

If you have a serial port, a null modem cable, and another computer - getting a serial log of the boot with failure would be extremely useful… otherwise if you can enable the on-screen debug output, and use a camera to snap pictures of each screenful during the boot and the failure, that would be useful.

When you land in KDL, best use “sc” or “bt” to produce a stack crawl also.

I would like to do that…but I am not well conversant with dev work and I do not know how to “open a Trac Ticket”. However, I can snap pictures of the debug output as well as the stack scrawl.

The error in gdb is something on the lines of “tcsetpgrp failed in terminal_inferior: invalid argument” in the thread “app_server”.

Please give me some pointers on how to open a Trac Ticket. Thanks for your reply!

Trac is our bug tracking software. You can access it here:

http://dev.haiku-os.org/

There are some instructions there on how to register and submit a bug :slight_smile:

  • Urias