Haiku wont boot from Hard drive

I have grub2 installed and working on one drive (/dev/sdb1) and want to install Haiku on my other drive (/dev/sda)
the harddrive im installing it onto is from an old windows xp machine.
I installed the anyboot to my usb jump drive, and here is what i have tried so far:

1:) used gparted to create a primary partition (/dev/sda1);
Booted Haiku from the usb, ran installer, formatted sda1 with Befs, installed successfully;
edited 40_custom with root=(hd0,1), ran update-grub;
rebooted, select the custom entry, screen turns black for a split second, grub menu pops back up.
tried booting from the harddrive itself (from the POST screen? im not an expert…) and i get an error along the lines of “error in master boot record”

2:) repeated everything from 1 except installed without queries, same problem.

3:) deleted all partitions from /dev/sda1, created extended partition, created logical partition (/dev/sda5);
ran installer like in 1;
edited 40_custom with root=(hd0,5), ran update-grub;
rebooted, selected the custom entry, grub returns: "error: invalid signature"
edited 40_custom with root=(hd0,6), ran update-grub, same problem.

If you want my computer specs, it is an hp Pavilion a6110n
amd atheron x64 dual core cpu

This sounds like a grub issue. If you boot from the usb stick and hold the shift can you select the hard disk and boot form it then?

see http://www.haiku-os.org/docs/userguide/en/bootloader.html


I use grub2 too and it works well for me. I even don’t need to edit a single file.
Did you create a “BeOS File system” partition and then formated it, or did you install a “BeOS File System” in an existing partition (just a simple format)?

Boot Linux and run fdisk to check the Haiku’s partition type. It should be set to “eb” (the “eb” hexadecimal value means that the partition contains a “BeOs File system”). If the partition type is not correct you can change it using fdisk.

Then run update-grub
Grub2 should automatically find your Haiku volume.

Does-it work better now ?

Note: I think you’ll can revert the changes you did in your grub2’s 40_custom file.

PS : IMHO, it’s not a good idea to have a file system not matching the partition type ! (at your own risk…)

it looks like you gave Grub the wrong path of your haiku partition.
you say you installed it on sda1,but in Grub ,you typed (hd0,1) wich is the primary partition on the primary HD.
so i guess the correct path would be (hd1,1),as you say you installed it on the sda1.
that sould fix your prob.

Thanks guys! I checked to make sure that the partition type matched the filesystem, and it didn’t so i fixed that and ran update-grub, it recognized Haiku but couldn’t boot it. Then i edited the custom_40 with (hd1,1) and that works now.