Haiku reboots at the end of loading


I just built a PC to run Haiku. Virtualbox didn’t satisfy my hunger anymore :wink:
It installed fine. I added GAG bootmanager since Haiku is only OS on this PC. It boots fine, loads desktop, I see the Deskbar and can get it even to open, but then the machine goes to reboot. What can there be so late in the loading that it forces reboot? It also happens on the liveCD.
PC: Athlon-64, 2GHz (3200+, Sock939)
40GB Maxtor IDE

That’s generally a triple-fault… which are extremely hard to debug.

If the machine has a serial port, you can try hooking up a null modem serial cable between it and another machine to capture the serial output from the kernel (which you may have to enable from the boot options menu) - this might help determine where the fault is occurring and give you something to open up a Trac ticket with.

Otherwise, you might have to start disabling features prior to boot - maybe disable DMA, SMP, APIC, etc. in the safe mode options menu until you find an option, or combination of options, that doesn’t cause the reboot issue.

Thanks! Started disabling stuff from bios, and voila! - it appears to be the integrated sound chip - ADI AD1986A SoundMax 6-channel HD.

BTW. A thing I noticed - there’s no way to set the screen frequency! I’m using a CRT, Hitachi CM721F, and this 60Hz is killing me… :stuck_out_tongue_winking_eye:

Ah, interesting - pretty sure the ADI SoundMax uses the HDA driver - you should open a bug report on that one, it might be interrupt related.

As for the video, that sounds like your video chip isn’t supported by any of the Haiku native drivers, and is thus running in VESA mode.

You can verify this by checking in /dev/graphics to see if another device (besides vesa, which is always loaded) is loaded there, and also from terminal executing:

listdev | grep accel

to see which accelerant has been loaded by the app_server.

The VESA driver doesn’t support setting different refresh rates, so you’ll be out of luck on that one :frowning:

Opened a bug. Haven’t bothered to do that in years… :stuck_out_tongue:
And out of luck I am - ‘listdev’ returned nothing so I guess I’m using VESA until I find a new graphics card.
Just discovered that eth is also not working. It appears to be there as /dev/net/via_rhine/0, but nothing moves on the cable. I’ll try some other cards, maybe Intels pro100/s works…
But that’s how alphas are, I guess…
Thanks for all the help!

EDIT: Intel Pro100/S works!

btw. Is there a binary Arora out there somewhere to test on Haiku?

Oops… that was supposed to be:

listimage | grep accel

Not sure what I was thinking :stuck_out_tongue: