Haiku on the Razer Blade 15 (can't boot)


#1

I want to put Haiku on a partition, just for fun, on my Razer Blade 15. The specs are as follows:
Intel Core i7-7850H
16gb DDR4
NVIDIA GeForce GTX 1070 (i heard somewhere that haiku apparently has no 3d acceleration, but I’ll still list it incase it’s the cause)
I simply cannot boot a live usb to test.
I have tried the following images:
-Haiku Beta r1
-Haiku Nightly rev52597
and a prebuilt one from last year that was marked as having efi support.
They all fail with the following panic, (with the exception of the beta, which just freezes up):

any help would be greatly appreciated.
i googled the error, but couldn’t find anything that fixed my issue


#2

This is KDL, the kernel debugging land. “get_boot_partitions failed” means the USB device hasn’t been found by the kernel. If you can type something, try “syslog”. If you can’t, you can try to enable the syslog display in the boot menu.
In both cases, you can see what Haiku does with the hardware devices, and maybe why the USB bus driver isn’t working for you.


#3

If you can’t boot the install media your alternative is to dd the install media to a partition from Linux and then make the partition bootable by compiling makebootabletiny and running it on the partition. You can then use the dd’d installer image to install to another (larger) partition. See here https://www.haiku-os.org/guides/installing_haiku_image_disk_partition/

Net booting also once worked, I remember it was broken at some point though, and I can’t remember the current status.


#4

Hello, and thanks for the post!

Would you like me to add your hardware to a hardware list? I’ll be adding several models into the Haiku Computer List and this thread later today: Computers compatible with Haiku (v2)

As for the problem, see if you can try holding Shift at startup to enter boot options as outlined here: https://www.haiku-os.org/docs/userguide/en/bootloader.html and see if you can disable hardware options or try booting in Safe Mode. Also, since I’m seeing the filesystem mentioned (with get_boot_partitions failed and vfs_mount_boot_file_system), maybe try booting via a DVD, a different USB port, and/or turn off USB 3.0 in BIOS/EFI. Hopefully, something will work and Haiku will successfully start up.