Haiku on Mac (new thread)

Started this thread as I was considering leaving Facebook and didn’t want to see the “Haiku on Mac” effort fade to oblivion.

That said, I’ll be posting updates on my efforts with it here, and hopefully people in the community can read, comment, contribute, etc. Thanks, everyone!

2 Likes

Not sure what the purpose of this thread is. I run Haiku natively on MacBookPro 11.3, installed on SSD via EFI boot (rEFId). Wired ethernet works (no BCM4360 wifi), framebuffer driver - Retina (no nVidia 750M), sound works (headphone jack) after warm reboot from other OS, XHCI also works (mounting secondary device, but cannot boot from USB3). Not ideal, but works within these restriction.

1 Like

I like the idea. Maybe a detailed HOWTO INSTALL video awswell?
Would love to have Haiku on my iMac (Retina 5K, 27-inch, Late 2015).

Thanks

Haiku 64-bit boots natively on my iMac (Retina 5K, 27-inch, Late 2017).
rEFInd is not needed.
Made an USB Stick with the nightly and install to an other USB Stick in order to get more space.
The Haiku Guides were a big help.
https://www.haiku-os.org/guides/uefi_booting

screenshot1

Graphics is Vesa at 3840x2160 not 5120 x 2880 Pixel. Tried a vesa file with different settings in /kernel/drivers with no success.
LAN works, WLAN does not. Sound is recognized but does not work. It is nice that the Bluetooth mouse and keyboard works out of the box.

I usehuge fonts on my HD screen but on this i would use 72pt fonts.

Haiku ran quite well on my 2011 MacBook Air, except for Wi-Fi not working (Broadcom).

Tried to run hrev53333 64-bit on my mid-2012 MacBook Pro from a burned CD via rEFInd (which I had installed previously). The system booted fine, but then when it got to the desktop screen, the graphics were glitched out so that I could barely see anything on the screen. It’s hard to describe exactly what it looked like; I’ll try to take a picture using my cellphone later, and insert it into this post. Anyway, the machine’s graphics processor is an Intel HD Graphics 4000, and the symptoms make me wonder if maybe Haiku doesn’t have proper support for that GPU yet…

Use the VESA driver by blacklisting the Intel one. And please open a bugreport about it with a syslog, output of listdev, and a picture of the screen.
https://www.haiku-os.org/guides/daily-tasks/blacklist-packages/

Quick update: The VESA driver works fine when the Intel driver is blacklisted; however, I’m uncertain of how I might obtain an accurate syslog, due to the graphical glitch and the fact that I’m booting it from a CD.

Bug report has been posted here.

if mouse and keyboard is working you can copy the syslog to a memory stick and examine later on a working machine

Yes, the touchpad and keyboard are working, but the graphical problem makes it near impossible to see what I’m doing.

You should not have graphical troubles getting to the Haiku Boot loader menu (if summoned).

You can save the previous syslog through the Haiku boot menu diagnostic if you have a USB drive/stick pre-plugged in a USB slot. Also, you can also review the current syslog state which should show you some of the video driver info You can snapshot the syslog info of your video driver output with your cellphone/camera that way (make sure the text is clear for devs). Page through the syslog output as needed.

As a workaround, just use a low default resolution like 800x600 or 1024x768 to get loaded into the main
desktop GUI - using the fail-safe driver (VESA). Then, you can change screen resolutions and apply them from there using the screen preference tool. I was able to test up to 1920x1440x32 on my external monitor.
on an older Intel IGP (2010).

I will try to obtain the syslog that way. You’re correct, the graphics were fine until it got to the desktop.

EDIT: I managed to make the screen a bit more readable by switching the resolution to 640x480x32 after boot. Syslog has been obtained and added to the bug report.

EDIT 2: Full output of “listdev” has been added to the report as a text file.

When I try to boot Haiku on my 2012 Mac mini it gets to the desktop then goes to KDL.

Would like to quickly ask whether any of the devs have had the chance to look at my bug report, which was posted above. It’s been a while since I reported it…

They usually dont look at bug reports posted in this forum. Best (correct) way is to file a ticket in the bug tracker.

Just got runnig Haiku on iMac 21.5" (first try, really very easy) from late 2009 (Core Duo 3.06 GHz, 12 GB RAM, 500 GB hdd, NVIDIA 9400 with 256 MB, 1920x1080 screen resolution).

Works:

  • Full screen resolution 1920x1080 with framebuffer driver
  • Ethernet

Do not know if working:

  • No sound (NVIDIA MCP79 audio). The device seems to be recognized.
  • No WiFi (Atheros AR928X). The network scan is working. For some reason only WPA2 networks are recognized as such, all other are listed as free. No success connecting to WEP.
  • SMB share shows nothing. Haiku installed on PC shows items from the same SMB share. EDIT: SMB is accessible, it was temporary network issue.

Installation steps.
For some reason iMac doesn’t boot from flash drive (I dd-ed latest Haiku x86_64 to device, i.e. /dev/sdc in Linux, not to partition, i.e. /dev/sda1). But it boots well from Haiku Beta 1 DVD.

  1. Booted from Haiku Beta 1 DVD and started live session.
  2. Following the UEFI tutorial, I downloaded UEFI Haiku loader and placed it in already existing EFI partition.
  3. Open Drive setup and formatted HFS+ mac partition as BFS named Haiku (I did not removed and re-created that partition, just formatted it).
  4. Using Installer, I installed Haiku to Haiku partition.

Because I had trouble ejecting DVD (no more macOS, Haiku cannot unmount and eject DVD from which it is running), when I booted and entered in select boot device menu, I could see both EFI Boot (Haiku) and mac. When I selected EFI Boot, iMac booted Haiku from DVD using bootmanager from HDD. When I ejected Haiku DVD, iMac didn’t boot from either EFI Boot or mac. So I did the following:

  1. Booted from Linux DVD, and using gdisk I changed the partition type of Haiku partition to EB00 (Haiku) instead of AF00 (Apple HFS+).

After that last change the mac entry disappeared from boot menu and I can successfully boot Haiku with no external bootloader. It seems EFI bootloader is sensible to the partition type (not only to filesystem type) from where it can boot.

Currently I cannot find any possibility to change partition type from within Haiku and Drive Setup says nothing about it. It would be helpful either to add this option to Drive Setup, or to do that during “Initialize Be File System” action.

1 Like

I tried on my Mac (iMac 2009 I think) I got passed all the icons, but then its black. I cant change boot setting though to that the keyboard doesnt work during boot session).

You can try blacklisting intel_extreme driver on your other computer and try your booting on your Mac again.

How do you mean?