Haiku on i7 4770 based PC with Intel HD 4600 GPU?

Have a new Maingear system that neither alpha 4 or nightly will boot on it. System is i7 4770 based with 16GB ram, Gigabyte G1 Sniper Z87 Motherboard, with on board Intel HD 4600 video.

Get no video when trying to boot from CD.

Same computer has a nVidia Ti750 Video Card and I get the same no video.

So no idea if just a video issue or?

Should Haiku boot on any of this?



I will try again but holding down SHIFT at boot time with the CD in the computer never bought up this bootloader screen where I could select different options. TJ

Hi macsociety,

Haiku should boot. I have a i7-4770s in the office and a i7-4712MQ in my notebook. Both run Haiku, albeit in VESA mode, as the HD4600 isn’t yet supported. Maybe it’s your additional nVidia card. So you may have to do some blacklisting (once you’re able to enter the boot options), or try removing the nvidia temporarily.


I sometimes have trouble booting Haiku on my laptop. Yup, this no video stuff.

Running it in fail-safe video mode always worked though.
You could try spacebar instead of shift, I guess.

Zero luck.

Shift or Space at boot does nothing for me.

I see DVD whirring but no video.

This is with ON Board Intel 4600 being the graphics card being used. It is HDMI. Maybe that is the issue? Maybe Haiku for video only works for DVI?

I may try turning off on board Intel and reconnecting to my nVidia 750ti DVI and try the Shift and Space again but via HDMI using on-board, nothing. No boot menu.


Please note I just bought a I7 a month ago.

While it booted okay from pre-formatted hard drives with Haiku installed, it refused to boot off the CD drive and USB sticks.

The CD problem was fixed by replacing the drive with an older drive from another computer that had already booted Haiku from CDs.

The USB problem was fixed by using the latest Anyboot Nightly.

PS. Check your BIOS settings, before buying this machine I was looking at another I7 that also would not boot Haiku. The store tech was able to get it working by disabling the Hypervisor functions that were in the BIOS settings.

Also while I don’t know the model number the nVidia card that did work in VESA mode on older Haiku-OS does not work on the later ones. But it works fine in Windows so I know the card is good. Note I have not tried that video card in over two months so the very latest may be okay.

Hope that helps.

I have two computers one with an AMD FX8320 and ASUS M5A97 R2.0 mainboard
The other with a Intel i7 4770K and GA B85M D3H, onchip HD 4600 video disabled in BIOS, using Nvidia GTX 660.
Same thing as macsociety trying to boot on the second computer with latest nightly. Also the same problem of not been able to press shift or space to open boot options.
I do not have these two problems with the first computer. I boot with a anyboot image on a USB stick