Haiku on Eee 900

Hi,

I try to get Haiku on a spare Eee 900, and it seems to boot fine. But when I come to the desktop it only shows a blue background and a cursor - nothing more happens, is this a known problem? I used the anyboot alpha2 image.

This is just for toying around - not a critical system :smiley:

Grab a nightly from here.

http://haiku-files.org/

R1A2 is pretty old now and theres been a ton of fixs for problems like this.

It does exactly the same thing (except the “DEVELOPMENT”-sign on the boot screen :slight_smile: ) Which one is the safest choice on that page?

Might be time to try booting in safe mode and selecting a knowk good screen resolution and using the safe mode graphics driver. I would boot in under safe mode anyways. Could be a driver conflict more then likely.

once you get past the bios splash screen hold shift or press the space bar a few times. This should occur before the Haiku splash screen.

sounds like driver conflict.

  1. boot into safe-mode (hold down SHIFT key at very start of boot)
  2. choose safe-mode boot option to disable drivers and some servers. That should get Haiku booted.
  3. conflict likely network related or maybe audio.

I tried that now :slight_smile: But now it only come to the boot-image (all the icons become highlighted and then nothing happens - I have tried to let it work for about 5 hours :smiley: )

You do not need 5 hours. If it doesn’t work in first 5 minutes (probably less) then giving it more time won’t do anything. Best to try other safe mode options. Many you can try out. Choose two or three to get through them faster.

For fail-safe graphics (VESA) choose a video mode also (ie: use fail-safe video + video resolution). That netbook uses Intel graphics. You will want to try VESA graphics - bug in Intel graphics driver that likely is affecting you and was fixed after Alpha2 release.