Haiku on a virtual machine (from the RAW image)

Trying to install Haiku on my virtual machine from the RAW HDD image:
sudo dd if=haiku.image of=/dev/hda bs=512 count=104857600 #100 * 1024^2
from Linux, but
PANIC: Unexpected exception “General Protection Exception” occured in kernel mode!

Welcome to Kernel Debugging Land…
occurs. What’s wrong? (using InnoTek VirtualBox as vm) May be, vm running problems or memory allocation bugs? :frowning:
What’s to do? :frowning:

I’ve run Haiku in “Q” (qemu wrapper, I believe) on MacOSX/PPC, but I’ve never tried VirtualBox.

Haiku has run successfully in VirtualBox once:

And it’s been reported that it doesn’t anymore:

You probably have to be a kernel coder to help debug/improve Haiku so that it can run in VirtualBox, but feel free to try it with different configurations and see if any one works, or even crashes differently. That could be a source of information. This could also be due to a problem within VirtualBox, but it’s most likely just something which is different from what Haiku expects, making it crash.

How to load haiku in Q in Mac OSX, can u help. I tried [the RAW image I used was(haiku-pre-alpha-r28862-raw.zip 97.62MB 8:55PM 9th January, 200)] and got this message:

Plex86/Bochs VGABios current-cvs 14 Jun 2006
This VGA/VBE Bios is released under the GNU LGPL

Please visit:
. http://bochs.sourceforge.net
. http://www.nongnu.org/vgabios

Bochs VBE Display Adopter enebled

QEMU BIOS - build: 11/01/06
$Revision: 1.174 $ $Date: 2006/10/17 16:48:05 $
Option: apmbios pcbios eltorito rombios32

ata0 master: QEMU HARDDISK ATA-7 Hard-Disk (4000 MBytes)
ata0 slave: QEMU HARDDISK ATA-7 Hard-Disk (4000 MBytes)
ata1 master: QEMU CD-ROM ATAPI-4 CD-Rom/DVD-ROM

Boot from Hard Disk 0 failed
CDROM boot faliour code : 0005
Boot from CD-Rom failed
FATAL: Could not read the boot disk

rename the disk image with a *.img extension,attach it to your primary disk.

Did that still got the above message.