Haiku On 2007 Small Fujitsu Machine FMV-Biblio-Loox-U50X/V


#1

I am a new comer to Haiku.
By chance, I came to know BeOS is alive in the name of Haiku.

Here is how I installed Haiku OS on my machine
(model FMV-Biblio-Loox-U50X/V of year 2007 from Fujitsu).

I followed instructions from haiku-os.org and made a bootable USB.
The first success was “haiku-r1alpha4”.
Unfortunately, the OS did not find the WIFI device driver.

I tried “haiku-master-hrev52357-x86_gcc2_hybrid-anyboot”.
Booting hrev52357 was not obvious for me.
I consulted “https://www.haiku-os.org/guides/troubleshooting”.
Booting was successful after setting “fail-safe video mode” in the booting process,

I installed Haiku on the partition “Haiku” of the hard drive on my machine.

Booting from the hard drive still required “fail-safe video mode” on.
Following “troubleshooting”
I deleted “#” at the beginning of the line of
“fail-safe video mode”
in the file
~/config/settings/kernel/drivers/kernel
(for easy booting).

This worked fine so I do not need to hold shift-key while booting Haiku.

I still need help for three issues.


#2

I need help for enabling WIFI.
Did someone managed this issue?

Here is the detail.
I turned on the WIFI of the machine.
I verified WIFI is active by Windows I kept on the same machine.
I rebooted the machine to start Haiku 0S again.
I opened “Terminal”.
Then, I issued the command “ls /dev/net/”.
The response was “rtl18139”.
I believe this is a driver/device for wired connection to internet
because the same command gives the same response
when I tried this again with WIFI turned off.


#3

I want to know how I can download packages
in the situation my installation of Haiku is off internet.
I do not have the router with wired connection.

The packages I have in mind are three.
TeX
LyX
BeTeX

I have a macOS machine and a windows machine
connected to the internet through WIFI.
I want to work around the problem by using these machines and a USB Stick.
In case, TeX is not available now, I will try to compile it.
But I still needs assistance because 30 years passed after I compiled TeX last time.


#4

Hello and welcome :slight_smile:

About your Wifi connection issues, did you tried installing the additional firmware? Here is a guide to do that:
https://www.haiku-os.org/guides/daily-tasks/wireless/

And about installing software without internet connection: is possible. You need to download the packages (.hpkg files) and then, copying (for example, using a USB drive) to your Fujitsu machine.

The .hpkg files must be put inside of /home/config/packages

If the package had some dependences, you will be noticed. This method could be a bit slow if the package had a lot of dependences.


#5

It seems your wifi should be Atheros. Most Atheros chips should be support by Haiku.

For my Intel ipro2200, even after installing wifi firmwares, I had something like this problem: https://dev.haiku-os.org/ticket/6423 (auto-configuration of network interface does not work automatically if another interface is listed in the settings file).

I did the following starting with hrev51146:

  1. Install wifi firmwares [Edit: waddlesplash said “Only iprowifi2100/2200 and some Broadcom devices (and Marvell?) need those firmwares.”].
  2. Read about ticket 6423.
  3. Edit /boot/system/settings/network/interface so that all my network interfaces are listed, with all of them set to auto. (See ticket 6423 for example of one interface.)
  4. Edit /boot/home/config/settings/boot/UserBootscript to include “ifconfig /dev/net/iprowif2200/0 auto-config”.
  5. Reboot.
  • I can now say “ifconfig” in Terminal and see my wifi device.
  • After “ifconfig /dev/net/iprowif2200/0 auto-config” I can get a list of wifi access points from the network icon next to the clock. Seems to not be recreated at each reboot, hence step 4, added above.
  • Still, I cannot auto-join the most-recently-used wireless network when rebooting. I could try adding to the UserBootscript a command to join a specific access point, but I have three access points, and always want the strongest one for where I am in the building. I might do this anyway, so I only need to manually select an access point 2/3 of the time. (>.>)

Things that did not work:

  1. Use the “Network” preflet (preference panel / control panel) to try to manually configure. (Device was not listed.)
  2. In Terminal without success (ifconfig claimed it is not a wireless device?):
    a. ifconfig /dev/net/iprowifi2200/0 list
    b. ifconfig /dev/net/iprowifi2200/0 scan
    c. ifconfig /dev/net/iprowifi2200/0 join SSIDnetworkname password
    d. ifconfig /dev/net/iprowifi2200/0 auto-config
    e. ifconfig /dev/net/iprowifi2200/0 up [Edit to add: think I also tried this.]
  3. Install wifi firmwares, reboot, and try everything again (also tried different order of commands).

For getting device info:

  1. Use the “Devices” application from the Haiku leaf/feather menu to make sure my device was detected and is listed as a wireless device.
  2. In Terminal, “ifconfig” to list network devices. (Wireless device was not listed.)
  3. In Terminal: “ls /dev/net” (as you have already done)
  4. Goto /boot/system/var/log then right-click on “syslog” file and open with TextSearch, then search things relevant terms such as “wifi”, “wireless”, “fail”, and anything else that seemed relevant. Look for interesting error messages.

NOTE:

  • If you disable a network interface, you might be unable to use it again until you reboot.
  • If are able to retrieve a list of wireless access points, and you try too many times fail to authenticate with wifi access points, wifi may stop working until you reboot. https://dev.haiku-os.org/ticket/12280

((Also, someone will probably point out things I’ve missed, unnecessary steps, or better ways of accomplishing something.))


#6

It has an Intel Atom processor and it is an old netbook so most likely it has the Intel 945GM or another type of Intel GPU used in netbooks of that era that isn’t supported which is broken on both nightlies and the new beta RC, a ticket is active for the bug for that type of Intel GPU here.


#7

Only iprowifi2100/2200 and some Broadcom devices (and Marvell?) need those firmwares. Everything else either has firmware in-tree (e.g. iprowifi4965) or needs no firmware (e.g. Atheros).


#8

Thank you for your comments.
I will be back on my machine at 18:00.


#9

https://kmuto.jp/debian/hcl/Fujitsu/FMV+LOOX+U50X/V

“AR242x / AR542x Wireless Network Adapter (PCI-Express)” should be supported.


#10

I tried Terminal --> “if config -a”.
It detects
“loop Hardware type: Local Loopback …”
and
“/dev/net/rtl18139/0 Hardware type: Ethernet …”
only.
On the other hand, Terminal–>“listdev” detects
“device 001c: AR242x / AR542x Wireless Network Adapter (PCI-Express)”
as well as
“device 8139: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter”.
Feather–>Application–>Devices also detects these two.

Thank you now I see Haiku detects the WIFI device.
I continue to work on WIFI.


#11

Your detailed instruction is really helpful.
I managed search for the keyword “WIFI” in syslog. (TextSearch and then StyledEdit)
I found the following pattern.
KERN [atheronswifi] (ath_pc) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1, 0x2)
add_memory_type_range(3771, 0xf0000000, 0x10000,0)
Set MTRRs to:
mtrr: 0: base: 0x3f670000, size: 0x10000, type: 0
mtrr: 1: base: 0x3f680000, size: 0x80000, type: 0
mtrr: 2: base: 0xf0000000, sise: 0x10000000, type: 0
mtrr: 3: base: 0x80000000, size: 0x80000000, type: 1
KERN [atheronswifi] (ath_pc) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1, 0x6)
KERN [atheronswifi] (ath_pc) unable to attach hardware; HAL status 3
Serial numbers #### in this pattern is consecutive.
It looks like an error in memory allocation.

What should I do next for WIFI?


#12

For my case, the screen turns black after the rocket icon is lit.
I follow the ticket to find the exact device name for the graphics controller.
Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
Indeed, my machine has two devices (“device 27a6” and “device 27a2”).

It is a good news that
I can work around the problem of graphics by some revision earlier than hrev50000.
This is because I read TeXLive2014 works on hrev49248.


#13


It says: “Hardware didn’t respond as expected”

You probably need to submit a bug report with the syslog.


#14

Thank you.
I managed to create a new ticket.


#15

Okay, that is another issue entirely, I recommend submitting a new ticket in that case.