Haiku installation issues

That’s what I did, the other reply is what I’d respond with here

If you want to use Grub, it is necessary to configure grub to find Haiku partition and boot from it.

If grub is not necessary, and you have no other partitions in the hard disk, start by deleting all partitions and recreating them with DriveSetup.

Maybe you need to tell us more information about the machine. How many hard disks, are you trying to keep other os installations ( Windows, Linux, etc ) ?

1 Like

One hard disk (320gb), no other operating systems. Refer to my reply to Midojiban for a bit more context

If it still is trying to boot grub, maybe you need to clean the bootsector of the drive first. A dd of zeros to the first megabytes of the disk to be sure, or a diskpart clean if you can use a windows 10 boot disk.

You can do all of this from the Haiku installer also, but I am not near a Haiku boot disk now to check the exact name of options. But in short, you need to remove some information about old partitions in that disk. Maybe deleting and recreating the partition table would solve it.

To simplify : boot a linux usb disk, dd zeros to the start of that 320GB disk.

Reboot in the Haiku installation, create partition table, partition, format partition as BeFS, back to installer, install on that partition. But I believe cleaning the disk is the key.

The Installer page in the User Guide talks about it. After selecting the destination drive, use “Write boot sector” from the “Tools” menu.

That’a what I did; clearing all previous partitions off of it before installing Haiku. I’ll take another jab at it after I finish eating, and come back with my results

Not only clean partitions, you need to clean the bootsector and partition table ( erase it ) . So, try with “Write Boot Sector”, as @Lrr pointed.

Ahoy @IdentityCrisis ,

Also you can read this thread - it is a recent one with Grub2 present on the machine and Haiku booted with configuring the chainloader mode.

It needs to be familiar with bootloaders and partition stuffs at least on basic level - it is also good to know that 64 bit Haiku boot needs EFI boot, 32 bit Haiku uses BIOS boot loader basically.
Haiku images have both available in the images, but recommended to use this way to boot successfully.
I had no experiences 32bit uefi Haiku bootloader, and bootloader - in bios compat mode - had not loaded the 64 bit Haiku install for me.

In case grub it loads the Haiku bootloader, so in case
32bit you must chainload config the bios version bootloader
64bit you must chainload config the uefi version 64 bit bootloader

There’s a small ESP (standard FAT) partition in the installer image, you can find the EFI bootloader there, but you can find it in the installed BFS volume, as the mentioned Installer material describes where are resides in the installed Haiku BFS filesystem, or in the installer Haiku instance as well.

I’m booting 64-bit merrily from BIOS. Perhaps more accurate to say that 64-bit can do both.

Also, I solved the “previous bootloader” problem by installing the Haiku Bootmanager with just the one entry and an insignificant 1-second delay. It just flashes onto the screen and continues booting.

Well, then you are lucky,

I have all icons in gray only - that happens in CSM.
Maybe I should set some bootloader option, but as not needed in EFI, I just use it that to boot - selecting the appropriate boot device.

1 Like

That means there is some leftover GRUB boot code in the master boot record of the disk.

You can erase that using the writembr command.

The “install boot menu” from Installer would also work, but it seems your disk uses the GPT partitioning scheme. Currently, our boot menu is not compatible with that (installing it would erase the GPT partition table), that explains why you get the “incompatible disk format” error, and this solution can’t be used.

Another option is to recreate the partition table of your disk using the intel partition map. This will also rewrite the bootsector with Haiku compatible MBR code (the same code that’s used by Windows, DOS, … everyone but Linux who puts a special GRUB loader there instead).

To all, I have referenced both this thread (or whatever) and the installation guide and was able to install Haiku successfully! You all have been immensely helpful and I wish the best to you all!


Increasingly, computers come without the “Legacy boot” option. Which is a pity: EFI is the answer to a question nobody ever asked. Except Microsoft.


EFI is not equal with Secure Boot only - which was required by Microsoft - but fine hardware tests under - Diagnosis - and many more features in the firmware
which was called once
and now EFI or UEFI,
depends on it is before standardize(d) or after that.

For example,
this HW detection feature or diagnosis was an entire partition in Win XP times - cca. 2004 - with bunch of single - Dos/Windows ?? - programs, so if I wanted to use it, then I had to spare that partition.
And why not use it ?

Of course, as it was before - the settings enabled or disabled – letting the consumer to utilize its capacity – depends on machine manufacturer and UEFI provider.

Fortunately DELL - who’s products I use lately - is generous and let the user set many things in their firmware.
But me now uses mainly portable PCs, not desktop PCs, those may provide more stuff to set(up) in their firmware :wink:

However …
simple music playing,
voicing error messages instead of error codes by beeping
or other interesting or strange ideas
before full booted OS - literally … had gone. :slight_smile:

I just installed Haiku on my Lenovo T540p. I formatted the entire drive to BeFS and continued the installation. It did NOT mark the drive as Active and will not boot to it. The only way to boot is with the original USB stick inserted, and it is tending to write new apps to that stick rather than to the internal drive. I have tried using DriveSetup to mark the partition as active, but that option is ghosted whether the drive is mounted our not. And for some reason, the USB stick is no longer usable as an installation medium, so to attempt to reinstall would require burning the stick again.
What am I doing wrong? I note that GPartEd is not available to download, so I would have to do that externally and load it as a distro rather than run it as an app.

This is a symptom of the partition not being recognised, with a wrong type or layout.
I don’t know the details of your laptop but generally with other Thinkpads you need to set mix boot mode Legacy/EFI with legacy first.
Then I would suggest to follow the official guide:

Don’t wipe the disk and format it directly in BFS, you need to create a partition first, as big as the disk if you want, and format it.
If it does not work for some reason, try these instruction to set an EFI partition:


Cleaned up older 32bit laptop earlier, then Installed Manjaro 64bit and Haiku32bit (BIOS/MBR) easy peasy :smiley:
Now I can boot into Manjaro too to checkout differences for the KDE applications and boot into Haiku with Haiku’s bootmanager.

1 Like

Try KShisen. There’s a difference in scores between the previous and the new Haiku version which is more generous. It would be interesting to compare with same versions on linux.

1 Like

Ahoy @zaivala23 ,

You informed us as you formatted the whole drive to BFS.
I have a bad news, and a good news as well.

it is no problem if you have installed Haiku 32 bit, and your drive is DOS formatted,
Then you can use Legacy Boot mode in your computer’s firmware to boot Haiku, as
the first stage of bootloader will find your next stage bootloader on that BFS partition.


If you would have a 64 bit Haiku installer USB key ready
then you must setup – EFI boot !

Your USB ,as if created successfully from an official Haiku x86_64 ISO image,
then contains a smaller FAT partition - labeled ‘haiku esp’ - which you have on your drive as well with its copied /directories / files on it.

So you must create first or last an additional FAT32 partition besides the BFS one on your system disk. If only Haiku will be on the disk, it can be so small, as on your USB key, some twentysomething size,
its type → ‘EFI system data’
it’s label I used ‘haiku esp’ as well, but it does not matter just such name that tells you that is your EFI partition on the system disk.
After formatted this FAT partiton as bootable, you can mount this and the other ‘haiku esp’ as well –
For already existing on the USB drive, you can select to mount as read-only, then you cannot damage it on the USB key
Then you can open them with Tracker, select all content from source FAT partition with all content of prepard EFI that helps you boot your installer drive … and copy all of its content onto the empty FAT partittion you have on your target system disk in the T540.
That should boot your new Haiku on BFS on your harddrive/SSD.

Do not worry if DriveSetup does not set bootable your BFS during drive preparation –
it would be handled with installer among last steps of installs.

You can read the messages of Installer in the up right corner in the Installer window – after files/directories/ copied to your new BFS system partition, then once the Haiku installer should write as it made/ finished Haiku boot(loader) setup on the drive.
This is stage one written onto the disk and makes bootable the BFS partition.
After that a small leaf icon should appears in front of the BFS partition just as on your USB key BFS drive it appears
You can set the BFS as bootable in DriveSetup as well during preparation of disklayout - using the partition flags modification menu Item under partiton, however in case EFI, the EFI partition should be bootable instead if system disk partittion. … as next stage lies here.
Also with such copy you don’t have to follow the complicated description in the official documaent of manual EFI setup with create BOOT dir. copy and rename a bootloader file that exists in the BFS filesystem in a specific directory / folder as well, but on a different name, so this way required to rename it … to stage one find it and you can see that is the
Haiku EFI bootloader of yours, you just made.
That handles EFI firmware supported boot options and load your Haiku (even select a specific snapshot with bootloader Options features.

If your machine Haiku installed only, then I suggest to initialize the whole disk as MBR instead of GPT, however Haiku can handle GPT drives. I would suggest due to DriveSetup. That would really need some refactoring/improvements/caring and adding some stability to too.
As there is issue/ticket about unbootable installs - whatever the boot media - when the partition won’t be set bootable during/after the installation :((…

I had such experience, me myself, as well, in the recent past - but with Haiku 32 bit.

you must initialize the partition using the intel partition map, then boot into the live environment and install haiku boot manager. then, haiku will start without the usb drive.