Haiku hangs on Medion Akoya E2293

I have critical problems with running Haiku on my Medion Akoya E3393 laptop. I guess it’s related to some drivers but I don’t know which and I don’t know how to find it out in a situation where nothing reacts anymore. Haiku boots up just fine and shows a blue background with the tracker in the top right corner as expected, see screenshot.
image
That’s all I can see on this device, however. I was already expecting the touch screen not to work, maybe the track pad too, but it seems that the system hangs completely, not even the clock gets updated (it’s still 12:51 there). It also doesn’t react to keyboard events or a USB mouse.
I tried that with the current beta release as well as a nightly which I downloaded about two weeks ago (and which works just fine on another laptop). I get the same result with both versions. Currently I’m using Linux on this device and it works with 100% driver support. I also tested FreeBSD 12 and it basically works, but without WiFi and touch.
I have no idea what could cause the problem here but it would be cool to get Haiku running on this more modern device and try how Haiku performs here. Some hardware information from the BIOS:
image
The following information isn’t visible in the picture:
Fab ID: FAB1
Total Memory: 4096MB
Memory Speed: 2400MHz
Does anyone have a idea how that can be solved?

Hello. Did you try booting in “safe mode” ? In this link, there is a tutorial about it

https://www.haiku-os.org/docs/userguide/en/bootloader.html

(basically, you need to push the SHIFT or the SPACEBAR key during the booting process, to enter into the boot loader menu, and there you will be able to choose different booting options, like “Safe Mode”, among others.

1 Like

A main stream Linux should be able to mount the Haiku boot partition (read-only). Do that after a failed Haiku bootup and get the /system/var/logs/syslog. It may contain some hints on what’s going wrong.

If FreeBSD doesn’t work with your wifi, Haiku most probably won’t either as we use FreeBSD network drivers thoug a compatibility layer.

Hi there,

Did you try disabling usb 3 in the boot menu? You can blacklist the xhci driver or turn it off. I experienced similar behavior on my desktop and with xhci blacklisted it boots fine!

Kind regards,

Tim

Thank you all for your help. I didn’t manage to access the boot menu before. Turns out I was pressing the spacebar too late in the boot process. Enabling the safe mode didn’t help that much unfortunately. I can see some desktop icons now but I can’t move the mouse (Touchscreen, Trackpad and USB mouse all don’t work). I can highlight the icons by using left and right arrow on the keyboard but that’s all I can do. It doesn’t react on any other key presses. Also the clock is still frozen (something must be totally wrong here?).
When trying to disable the xhci driver, I get an even worse result. It complains that it can’t find the boot USB-stick anymore, it only finds the internal SSD with Linux. I tried that with both the USB 2 and USB 3 port with no differences. See screenshot:
image
And thanks for the hint with the Wifi but I know that already. While Wifi is important for everyday usage, I can’t replace Linux on this device for now anyway so I only want to do some testing.
Unfortunately I had some problems with getting the syslog. If I try to mount it on Linux, it says unknown file system type befs. If I try to mount it on my Haiku desktop computer, it looks like this:
image
When booting the USB-stick directly, it works but then the syslog file is overwritten with new content. I think the syslog.old file is the relevant one now, correct? Here’s the content: https://paste.bka.li/view/bf3d7733