Haiku changes active partition when dual booting from GRUB

I have installed Haiku Alpha 1 for dual booting with PC Linux OS via GRUB on an Acer 529ATX laptop. The current setup of the partitions is as follows:

primary partition 1: Haiku Alpha 1
primary partition 2: PC Linux OS

Active partition: primary partition 2
Boot loader: GRUB installed on primary partition 2.

The set up works perfectly and I can boot into both PC Linux OS and Haiku without problems - except for one glitch. When I boot into Haiku, it changes the active partition (boot flag) from partition 2 to partition 1. Thus, on the next boot, GRUB is bypassed, the option to boot into PC Linux OS is not presented and the laptop boots directly into Haiku. If I want to boot into PC Linux OS, I have to change the active partition (boot flag) back to primary partition 2 using, e.g., cfdisk on the Parted Magic CD first.

Is there a way to stop Haiku resetting the boot flag when it boots? I did a quick check on the existing bugs list and also this forum but I couldn’t see any mention of this particular problem.

The best solution is to install boot manager to MBR, not partition. It can either be GRUB or Haiku’s bootman ( or another one ).

I don’t agree with tonestone57 : installing a boot manager in the MBR is not a good solution. It doesn’t respect the Intel’s partitionning system spécifications and may cause your Linux system not to boot anymore because some tools ( fdisk /mbr, fixmbr…) writes a standard MBR code.
However you should open a new ticket.

OK, thanks for both comments. I will take starseed’s advice and open a new ticket when I can get into the Bug Tracking site.