Haiku Beta R4 USB stick freezes my old laptop BIOS

I have an old Atom 64 bit dual CPU laptop with an Award Bios 6.0.0GP.
I have run a multitude of linuxes on it from AntiX to Zorin as well as BSD and even React at one point.

However, I am encountering a mysterious bug.
If I insert the Haiku USB stick, the BIOS freezes solid and I have to reset.
If I remove the USB stick and reboot, everything goes back to normal.

During the POST if I insert the Haiku USB stick, it freezes instantly whether the PC enumerating the hard disks, running the RAM check whatever… requires me to unplug and plug the power.

I have flashed the image onto four different, known-good USB sticks and tried all four USB ports:
Instantly freezes the POST. Cannot press DEL, F10 or F2. have to unplug the power.

The USB sticks all worked in another old PC that I use.

I even put Mint Linux back on one of the USB sticks to see if somehow the USB sticks were fundamentally alteredm but it booted up fine. Once I put Haiku back on it, though, the insta-freeze returned.

Amazingly, even when using a USB3 powered hub, the moment I plug the Haiku USB stick into ANY of the ports, the PC freezes solid.

I’ve been playing around with PCs for nearly 40 years now and I’ve never had this exact error happen before…

Sure, I’ve had faulty hardware freeze a computer when plugged in, plenty of times in my career, and of course I’ve had USB images that were not compatible or faulty that freeze once the USB stick starts to load… but never an apparent software issue causing BIOS to crash before the USB stick even appears in the boot list.

TLDR: My Haiku Beta R4 USB stick crashes my computer BIOS the moment it is plugged in. Any ideas how I could test Haiku on this old dog of a PC?

1 Like

Further testing.
I used the installer on the USB stick in a second PC to install Haiku onto a USB HDD.
The USB HDD now also causes the PC to freeze as soon as the POST screen starts (i.e. before memory check or port/device enumeration.)

Where it usually says “Memory Testing : xxxxxxxxxkb” only the first letter “M” displays. LOL

Now, that is interesting.

I have that happen here, with an AMD Thurion laptop. Had considered an effect of the usb drive I was using, since it is already a little old. Same things as you : would hang or freeze in bios, or before booting… Sometimes just removing the usb disk would allow the computer to continue booting.

What I observed was that , by connecting the drive at the right time, the machine would boot to Haiku´s desktop and work normally from it.
I did not take not of exactly when the problem would occur or when it would work, but ( only a guess ) is that by not having the drive connected when bios is checking for bootable things could allow it to boot. and not freeze the machine.

What I find interesting is that the moment I plug the device in, the BIOS freezes solid.
It’s like a kill-stick, even via a USB hub.

On the off chance that it was the 32 bit bios that was causing the issue, I repeated the above tests with the 32 bit hybrid version.

Same situation, even Haiku preinstalled onto an HDD I formatted and initialised in Linux causes the BIOS to hang instantly,

Maybe the problem is with your laptop’s USB controller then? Or maybe it’s a combination of the controller and it’s interaction with the Haiku install/image?

Presumably your laptop detects the USB drive fine, handles enumeration, and then maybe attempts to determine if it’s a bootable device?

Dear @GraXXoR,

The problem is possibly with bootloader detection of your hardware and/or BIOS/UEFI configuration.

Q1 :
Is there an optical drive in your machine ?

If so, then I suggest to obtain a DVD RW disc and write R1B4 image onto there.

If the bootloader can load Haiku from optical drive
after you selected
"Safe graphics - using VESA mode blablabla"
from Boot options
then you can have the same issue as some of us have :

—> you can boot Haiku only from CD or DVD image not USB
→ your chipset is might be an ATI/AMD product.

To reach Haiku ‘Boot options’

on older machines - with BIOS firmware:

keep ‘SHIFT’ button pushed meanwhile Haiku loads from CD or DVD

on newer machines – UEFI firmware :

keep ‘SPACE’ button pushed meanwhile Haiku loads from CD or DVD

So, from this happens then you could boot onto Haiku Desktop finally …

… then comes my next important question …

Q2 :
Is your machine has an ATI/AMD chipset ?

It is interesting because then this issue became enough wider to get developers’ attention,

to refactor my ticket about ATI/AMD chipset issue – ticket #18076

(#18076 (USB Boot hangs on FUJITSU AMILO LI 1720 laptop - possibly as chipset is ATI (AMD) ?) – Haiku)

that I’ve just updated recently – added supplemental note (comment 17)

Thanks in advance for your test and/or reply !.. :))

Since, it freeze immediately, I would think that your BIOS doesn’t like something with partition scheme/partition on the stick. An interesting test would be to add a partition formatted BFS to a stick with a linux distro and see if it still boot.

Hello people, thank you for the responses.

The PC is an Atom 330 machine with 2GB RAM and a 64GB PATA SSD.
There is no optical drive…

In the end, I removed the SSD… placed it in a USB case.
Plugged it into another computer.
Booted Haiku from a USB stick, installed Haiku onto the USB SSD.
Removed the HDD from the case and put it back into the PC.

Haiku booted in seconds. No stallage.

It seems that if the image is connected via USB the computer freezes… via the ATA bus, there is no such problem.

Once again, thank you for your help.

6 Likes

That’s some serious dedication! Thank you for being persistent! Let us know what you think of Haiku.

1 Like

I was a fan of BeOS back in the day and have followed Haiku’s path to (almost) release for more than a decade.

I intend to try it out on a range of machines from current generation high-core-count hardware down to legacy Atom class hardware and document and “hardships” I face along the way.

I’m totally up for beta testing any specific aspects of the OS or ported packages.

As for my Atom 330 experience.
Unbelievable! I have been using a mixture of fluxbox and XCFE and Enlightenment 16 based Linux builds on it over the years and was never satisfied with its sluggish performance.

But putting Haiku beta 4 on it has made it completely useable, and it is even very acceptable with the range of web apps that I intend to use it for!

I’ll keep posting my thoughts and observations.

So far, colour me impressed at the progress!

8 Likes

Hello,what is your boot sequence? I have issues booting Beta 4, and I have an ATI Radeon Xpress 200M. (See my post in the forum’s here). I usually set my removable devices first rather than hard disk because I usually boot off live USB systems (Puppy Linux, Devuan,Zeven OS) to do most of my work after my hard disk crashed.

Hi there. Boot sequence is

USB → SATA → ATA

But there is no SATA device (it’s an E SATA Port for additional external storage) so that is skipped and it loads off the internal ATA drive which I replaced with an ATA SSD (in this case as compact flash disk upgraded from an old Toshiba microdrive.

The machine is designed for industrial or kiosk use, fanless, solid metal construction and hardened glass screen with capacitive touch. It’s a criminally underpowered CPU (ancient Atom?) to keep the temperatures manageable since its display is only 8 inches wide and the case is super compact.

I also suffered it on my lagecy BIOS host. If your machine can detect a USB stick as a HDD, you may try the following steps:

  1. Convert Anyboot ISO to a raw image, refer to Installing a Haiku Image to a Disk Partition.
  2. Write the raw image to USB stick, use dd in Linux or physdiskwrite in Windows.
  3. Change the HDD boot priority in BIOS, set the USB stick as the first.

Good luck.

1 Like

I did a dd on my USB flash drive using the Beta 4. But it still happens. I also set my removable storage (including network boot) first,hard disk last.
But it still cannot boot.
I will try the raw image method when I have free time. Thank you.

I know this discussion is already basically over, but I wanted to say that, since the BIOS freezes the moment you plug in that USB drive, and that happens no matter which USB port you use, I think it must be either an issue with the BIOS itself, or a hardware issue in either the USB drive or the computer’s USB controller. If it’s hardware, I’d say it might be more likely to be an issue with the drive… However, although I’ve never seen any instances of USB controllers going bad, that doesn’t mean it can’t happen. Just thought I’d put in my two cents and give a couple of possibilities as to why it doesn’t work.

1 Like

Maybe the issue is caused by GPT. If you attempt to make a USB bootable stick from the recent FreeBSD(e.g. 13.1) img file, you will get the same symptom. However, it is worthwhile to have the above mentioned method a try. At least, it works for me.

I’ve never seen anything able to instafreeze a bios before. When i reformat the stick as anything else, it’s completely fine in the machine and this machine has had windows XP, windows 7, Suse, Mints 13 thru 19, and since it started to feel slow, AntiX, Puppy and even Minuet at one point. Never froze.

Must just be a weird combination of factors conspiring. Lol.

Hello @dbs,

I could not boot my laptop from USB with ATI Radeon Xpress 200M chipset but only from optical disk as it had ATA interface.
I had Intel CPU in my laptop and this ATI chipset has multiple versions and used for AMD CPUs as well.

As @PulkoMandy shared it with us in another thread this chipset has problematic non-standard solutions regarding USB and other HW related stuff even he gave up on resolving it and there is no hope someone would develop proper drivers to have proper USB support - at least it seems actually.
So bootloader cannot detect well your USB drive - it detects your hub, but nothing about that plugged in. I have a living ticket about it - #18076 -

Another issue was the chipset has the affected ATI Radeon Xpress 200M video card in NorthBridge as well, so VESA must be selected as boot option even if you have boot started from optical disc media.

Looks like I have to just continue using Beta 3 if I want Haiku until there is a solution.

Please open a ticket, otherwise issues won’t be known and can’t be fixed.

https://dev.haiku-os.org