Haiku beta 3 won't boot

ive successfully booted the beta 2 from usb key on my hp eleitebook folio 9480m, but beta 3 just hangs

i’ve set the bios to legacy mode, the startup screen shows, all the icons colourise, but then the screen just goes blank, kinda flashes on and off if that makes sense

not sure why bea 2 would work fine but beta 3 not? any ideas?

kinda my first try after that would be… what happens if i use another usb stick… and do a check on how the iso flashed, lets say… through ddrescue

hey thanks for that,
tried new usb key, and new download of the iso, with the same results
flashed it with etcher, not too sure how to use ddrescue tbh

if it helps, when the blank screen ‘flashes’, the wifi button also flashes.


just tried it on my lenovo thinkpad, same results

This could be the intel_extreme driver which tries to support your hardware.
Please try to boot in fail-safe graphics mode and make a bug report.

no difference

pushed and held shift key as soon as i selected the haiku usb, pretty sure that’s right?

to get in the bootloader menu, it’s possible you have to bump the spacebar several times just after selecting the usb key for booting.

thanks, yep works, booted in and everyting works as expected with the failsafe graphics driver.
sorry a bit clueless, where do i make a bug report?

https://dev.haiku-os.org/ is where bugs are reported. There is some good info on how to report bugs in the links. The more info the easier for someone to try and fix it. That being said, it is better to report bugs with less info than not reporting at all.

1 Like