Haiku 64bit runs well on Lenovo Thinkpad T450s

A few days ago I bought a used Thinkpad 450s in very good condition. My intention is to try to run Haiku on it as the main and only OS. I am writing this on it right now. My first experience with thinkpad keyboard…it’s amazing !

Hardware: i5, 4GB RAM, 500GB hard disk, 14’’ screen 1920x1080.
OS: Haiku 64-bit latest nightlies, currently hrev53452.

EFI booting after creating manually everything using DriveSetup. No problem at all.

Graphics card was not detected (Intel HD 5500) but runs on 1920x1080 OK. From installation USB I am certain that it showed VESA on screen prefrences. Now it shows “Framebuffer”. Don’t know why. Also no other resolution is available. Increased text size and working without problem. But I really miss the ability to adjust brightness. Aside from other things it makes big difference on battery usage. Any chance of supporting that card?

Sound works both on speakers and headphones (HDA) :slight_smile:
Wireless works ! (idualwifi7260).
Touchpad works but slow motion that cannot make it faster. Special thinkpad cursor works.
Both 2 batteries are detected and work OK.
Keyboard backlight works but I suspect this is handled directly in non-OS layer.

OS seems stable enough.
I do have a strange problem with Haiku Depot which I didn’t see it mentioned in the forums, so I am wondering…
I get the following message when loading HaikuDepot:
I cannot see Featured packages but I can search “All packages” and install without a problem.
Also OS updates work OK. But I would like to find a way to resolve it.

I plan to put the info on our hardware compatibility lists. Will search for the correct place…


You might want to show up on IRC to see if someone can help you debug the video card issue.

I have the same issues with Haiku-Depot on several machines. Dunno why, haven’t been able to solve it.

This happens because of a regression in Installer – it doesn’t create cache directory.
See this ticket https://dev.haiku-os.org/ticket/15145#comment:2

You need to create cache dir manually:

unmount ~/config
mkdir ~/config/cache

and reboot.


Glad that there is a work-around! I will try it tonight at home :slight_smile:

It worked :slight_smile:
But I cannot select a package in “Featured packages” with the mouse !!! Using arrow keys it selects, but doesn’t scroll.

Yes, this is a missing feature, see https://dev.haiku-os.org/ticket/11675.

Any idea why selecting featured packages with mouse is broken?

Found out why I was seeing “framebuffer” and no other available resolutions except of the native one (1920x1080) although I remember at some point I had seen VESA and multiple resolution available.

On BIOS boot it detects a LGD 14" monitor and shows VESA driver and multiple available resolutions.
On EFI boot it shows only framebuffer and I have only 1920x1080 available.

So I am doing BIOS booting now since it behaves better.

The EFI framebuffer driver does not allow us to chanoe the resolution “live”. We should probably allow the screen preferences to still set a resolution and offer to reboot, since it is possible to do that by manual editing of the configuration file.

1 Like

Thanks for explaining. I have no problem with the inability to change resolution. I am using it always with the native one. I just thought that BIOS detection and VESA driver is better. Is it correct? I haven’t tried to test the two drivers for performance yet. Are there differences?

No performance difference. As for the resolution picked, we are dependant on the BIOS behavior in either case. Depending on where the manufacturer put their focus, one or the other will work better on your hardware.


I took the tip and got one myself, and am writing from it here. I don’t notice any backlight, nor evidence of a 2nd battery (perhaps there is none.)

The weird thing is that it didn’t work very well at first, but after an hour or two it fixed itself.

  • The “mouse” function keys above the touchpad: at first, ineffective, and invisible to Mouse Preference. Eventually they started to work, and be seen by the preference utility as mouse buttons 1, 2 and 3.

  • WebPositive: couldn’t connect to anything (when telnet etc. could.) Now it can, evidently.

Not even a reboot, these improvements just happened miraculously. And they’re available now right on startup, don’t have wait for this healing process every session.

The touchpad seems about normal to me, when it’s working. It’s terribly sensitive to something I do when I’m typing, which can be irritating, and when I was trying to manage without the “mouse buttons”, there were some puzzling behaviors where it would fly off to the margins. It’s a used laptop, some local corporate office, cleaned off and set up with some Microsoft OS that’s gone now.

It has 2 batteries: an internal one and a removable one. Haiku reports 2 batteries if you get info on battery icon, which is correct.
Keyboard back-light works by pressing Fn and spacebar.
Wireless needed to give password and “save configuration” a few times but now it auto-connects quickly on each startup.
As described above I used both EFI and BIOS boot but I am using the latter now because I feel it behaves better related to screen/graphics driving.
I found touchpad movement very slow, even after I adjusted it, so I am using external mouse.

In general, in my case, everything important works as described above and OS stability is great.
Yesterday I gave a demo to a colleague where I opened a dozen applications and demos, playing music and videos e.t.c. Not the least lag using UI with all 4 cores constantly close to ~80%. I only needed to kill a couple applications at the end that didn’t respond to exit.

Mine is i5, 4Gb memory and 500Gb hard disk.

Maybe related: https://dev.haiku-os.org/ticket/14236

Works great on my T400

1 Like

I have H1B1 installed on a Dell Inspiron 1720 laptop.

It is running with Intel Core 2 Duo 2.6Ghz, 4Gb DDR2 SDRAM, 2x 2Tb HD, Sigmatel 9205 audio, and so forth. Although you have to work around to get the sound working properly, it works great!