[GSOC 2024] MDNS / Bonjour / Avahi network discovery

Wifi with both username and password is WPA2 Enterprise.
That is not supported on Haiku yet,a ticket for it has been created in 2012: #8850 (wpa_supplicant and WPA2 enterprise support) – Haiku
There is also a rather new patch available that adds support for it,but it’s not yet merged as nobody tested it yet: Add EAP gui configuration (WPA2 Enterprise) by nephele-gh · Pull Request #6 · haiku/wpa_supplicant · GitHub

I have not tried this but does free Wi-Fi but need authentication in webpage works?(for example Wi-Fi in the public library or Starbucks)

if you mean captive portals then yes. kinda. It needs a http only site to redirect,
in theory there is a RFC that over DHCP properly advertises captive portals. But I’ve yet to see it implemented anywhere.

sites like http://neverssl.com can be used for example

well, that’s how it works everywhere else as well, right? So, yes, it works as good as the technology allows?

Any advice for which version of mdnsresponder(windows,MacBook etc) and vscode on haiku I can download to run the code?

VS Code is not available for Haiku.

So how would you suggest me run the code? I saw people suggesting Koder and Pe?

No, most other OS implement this by calling home to a known adress over http and checking the response, and then automatically opening the captive portal.

In Haiku you just get not working https sites unless you know why.

I recommend Genio if you need a bigger editor/IDE, comparable to VS Code.
Pe and Koder are more like Notepad plus Syntax Highlighting and some extra features, but not nearly as feature-rich.
They’re all native Haiku applications, available in the HaikuDepot.
If you’re not happy with them, there are also ported applications like KDevelop and QtCreator available, but they don’t integrate as good with the OS.

1 Like

I downloaded bonjour sdk from Sign In - Apple as you specified. However, it seems like the file only has dns-sd(which implements rfc 6763) and no rfc 6762 is found.Maybe I should try mDNSResponder/mDNSPosix at main · apple-oss-distributions/mDNSResponder · GitHub?

I got an error by trying to install Genio. Any solution to this?

It appears the package you downloaded from github requires a nightly build of Haiku. You should search for and install it directly from within the HaikuDepot application since those are built against the latest beta release of Haiku.

Is this the right place to find(https://depot.haiku-os.org/#!/pkg/genio/haikuports/haikuports_x86_64/2/1/0/-/1/x86_64?bcguid=bc18-DCIY)? But I did not see any place for download. And accessing https://eu.hpkg.haiku-os.org:443/haikuports/master/x86_64/current tells me forbidden

There is no need to use a browser. Just open HaikuDepot from the applications menu.

1 Like

You should spend some more time using and knowing how to use Haiku, because it seems that you still don’t know how to “daily-use” it. Regardless of if you prefer to code for Haiku from other foreign OSes (I could observe you tried to compile from Windows), I think it would be more benefitial for you to directly use Haiku instead (if your current device allows you to install it), or at least from a virtual machine (you can use QEMU, Virtual Box, etc.) to do all the tasks, coding-related or not. Also please check out the Quick Tour and the User Guide.


You need to use nightly build of Haiku, not beta version, nightly version, it has improvements and fixes.

1 Like

I feel like this directory looks better than the boujoun sdk as it contains more completed files. But not sure which one is going to work better

This looks like is built on top of the SDK, I presume?
I would recommend starting with compiling this and see what happens unless you want to create a brand new implementation leveraging the SDK.

Do you mean compiling boujoun SDK or the one you suggest me?

SDK stands for software development kit, the reason only the high level stuff is available is that this is meant for software that wants to use the OS capabilities for service publishing and discovery.

The correct thing to try and compile is the git repository from apples oss releases (like the github mirror you had)