Getting USB flash drives to work in BeOS

I never know where to put BeOS questions or comments, since it’s sort of related to Haiku but often not directly related.

Anyway, if any BeOS users notice problems getting USB flash drives working in BeOS after installing the USB SCSI drivers and patches, try installing different OpenTrackers. The main symptom is file-transfers not finishing and locking up. What I’ve tried so far is “OpenTracker_x86.pkg” from BeShare and also “” from Pulkomandy’s archive. They both work great in BeOS 5.03 Pro and Beos Dev Edition 1.1, and cleared up the file-transfer problem. Not sure why it works, but it does. Don’t forget to first install “” and “”, otherwise USB flashdrives won’t work at all. Also, you’ll almost surely need to uncomment the line “ignore_sysinit2 true” in the USB SCSI config file to avoid KDL on reboot.

Some OpenTrackers resulted in the file-transfer problem, but I forget which ones. LocaleTracker_1.3.1 had the same problem.

Correction to the above: does NOT work well with USB either. “OpenTracker_x86.pkg” does. I haven’t tried all the opentrackers, so there might be others that work well, but I’m happy with the one that works.

FYI, I don’t know if it builds anymore, but the last (non-Haiku) OpenTracker’s source code can be found here.