Getting past the boot screen from the livecd

I can boot the haiku live disk.

I have to push space bar to get the boot menu.

I can select the correct monitor setting.

Start the machine booting.

Watch the icons light up.

Then when its all done the screen goes black.

It come back on and then does nothing. Except for the fans pick up speed like the processers are maxed out.

I have a dell opti-plex gx-280 with a gig of ram with intel 915 graphics.

Any idea whats going wrong?

Anything I can try?

Thanks for any help, kelean.

Sounds like you’re getting nailed by the intel_extreme driver issues (BTW, I used to use a gx280 at work :slight_smile:

Go into the safe mode options menu and choose the “Fail safe video” option before booting.

This should tell it not to use the intel_extreme driver, but instead to use VESA mode.

If this works, and once you have Haiku installed, you can prevent the intel_extreme driver from loading every time by renaming the driver.

From a terminal:

mv /boot/system/add-ons/kernel/drivers/bin/intel_extreme /boot/system/add-ons/kernel/drivers/bin/intel_extreme.disabled

There are several bugs reporting this issue already:

You can add your comments to them as well if you wish.


  • Urias

I have tried fail safe mode. I have tried all of the options. I have not been able to get past the boot up screen with the haiku logo and the icons. They all light up then the screen goes blank and I am stuck. I will try it again, maybe I missed something.

Fail-Safe Mode + select Video Mode ( you have to do both of these )

When you select fail-safe mode you should also select a screen resolution ( ie: 1024x768x32 ) in previous screen.

failsafe mode = vesa mode
video mode allows you to set your resolution to a supported one

Right, as tonestone57 suggests, selecting the fail safe video mode resolution is not selecting the fail safe video option from the safe mode options menu.

You’re looking for the menu that has the options to disable DMA, APIC, etc. - you’ll see a Fail Safe video option in there.

Thank you, I finally understand. I was able to boot haiku. I had to use different screen resolution. I am writing this haiku now.

I am going to try some larger resolutions. I think I am 800x600 now.

This is very cool.

Thanks again, kelean

I rebooted chose fail safe video mode and chose 1024x768. It looks much better now.

For a alpha release haiku is very amazing.

Once booted into VESA, you can change the resolution with the Screen preferences.

Note: You will only be able to use resolutions available from your video card’s VESA bios.