Getting Ethernet & Sound to working from new USB Install

Grabbed the recent nightly and created a bootable USB Thumb Drive.

I think the build was hrev50874 or I may have grabbed it last week and was hrev50867 but was one in the last week or so.

Good news is she boots on my i7 based system that I had tried before that failed. So some things have been changed since I last tried.

But as normal, two important things everyone wants to work out of the box is ethernet, so I can get on the internet, and sound, so I can play music, etc…

In my case, both ethernet and sound have failed. Always seems to be an issue in the years me tinkering with Haiku. One or the other or both always fail.

Anyway, my system is an i7 4770 based Maingear system. Gigabyte G1.Sniper Z87 based motherboard. Video card is a nVidia 750ti (nice that Haiku worked with it this time. Last time I tried I got no video.

Anyway, the manual says the following about the sound and ethernet on this motherboard:

Sound card is on-board
Creative Sound Core 3D

Ethernet is on-board
Qualcomm Atheros Killer E2201 LAN

Should Haiku work with these?

If not, what are my options" PCI Ethernet NIC for my PCI slot? Same, PCI or PCI-E Card for soundcard?



For sound, you can try to install the “opensound” package, which has additional audio drivers.

For network, yes, a PCI card could work. We are using drivers from FreeBSD 9 at the moment, which is a bit old. We should update to a newer version (10 or 11) to get better network hardware support.

1 Like

You happen to know if Realtek 8139 chipset will work? I happen to have a spare one that may be laying around. 10/100. Old and slow but for basic internet, may be OK.


Realtek 8139 works for me.

Cool, maybe I will find that card and slap it in the system and give it a whirl. Thanks, TJ

Tried to install a PCI Ethernet card in my Maingear today but the system locks up and does not boot with said card installed. Not being a Bios and PC junkie (I’m a Mac dude) I figure its a Bios setting that needs to be set to allow both network devices to work at same time or I have to disable the on-board for the PIC Nic to work. Was not worth it to try those things so passed for now. Asking Gigabyte if way to allow both to work. If that fails, guess I will pass on Haiku for now. Not worth using my old 10/100 versus onboard 10/100/1000 for everything else if I can’t get the two to work. Not worth buyng a new Nic for now either as I have too many other things going on. Maybe again one day I will look into this. TJ


device Network controller (Ethernet controller) [2|0|0]
vendor 10ec: Realtek Semiconductor Co., Ltd.
device 8168: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

Work fine.