Fix filetype icon mess

Good day,

Well, in my process of learning things about Haiku, sometimes I do mess stuff, and this time I did it with the Filetype Icon for Source Code:


Where the Source Code Icon is messed. Now I don’t know how to get it back to normal. Yes, I was working on an icon for Python files so I could identify them visually, and messed the thing:

So now I need to know how to reset the Source Code icon. I would appreciate any hint on doing that without reinsalling Haiku :slight_smile:

Thanks and Regards,

You can save source code icon somewhere and then drop it to Python File icon.

Good day @X512,

How could I haven’t thought of that!!.. yep… just get the icon from another Haiku install and get it there. Will do. Thanks!!! (i need winter to come ASAP… this heat is boiling my brain :rofl::rofl:)


1 Like

It’s easier than that: Just copy /boot/system/data/mime_db/text/x-source-code to /boot/home/config/settings/mime_db/text/ and overwrite your blunder.

Good thing /boot/system/data/mime_db is “read-only”, eh? :slight_smile:

(Edited: substitute ‘x-source-code’ for the right MIME type…)


I sort of wonder why there’s ‘/boot/home/config/settings/mime_db/text/x-source-code’ on my system at all! I didn’t put it there, and it’s dated several days after I installed the system, so something must have written it.

In fact, to fix things I guess you could go even simpler than Humdinger suggests :slightly_smiling_face: Just delete that file, and the tracker should revert to the /boot/system/… one.

1 Like

Pete’s right, the system MIMEs are shining through, once you remove a MIME type from the ~/config/settings hierarchy.

It’s possible that you’ve installed an editor like Koder and assigned it to be the standard app to open a certain file type instead of the default Pe (e.g. with the “Open with…” dialog).
Any changes from the system default creates an entry in the ~/config/settings hierarchy.

1 Like

Of course…! That’s become so habitual that I tend to forget I’ve done it! Duhhh

hehehe… Yes. I like this “feature” on OSes, that is why I like Haiku and Silverblue.
Removing the files inside mime_db did the trick.
Thanks both.