First Impressions

I’ve been using Haiku just about every day now. I even got a system for home after I started using the old Xeon-based machine I found in the trash pile at work. The old Xeon machine is better supported, has Radeon video card and the built in audio chipset is supported through the HD Audio driver. It has 32-bit Haiku on it.

The machine I bought for home use is a i5 Dell Optiplex Micro 7040 and while it is using the VESA drive and the HD Audio chipset does not work, it is still a fun machine.

This really takes me back to the old BeOS days. I am having fun. My WebPositive crashing issue went away after I did the software update on the 32-bit Haiku machine and the 64-bit machine never had the issue but I did the software update anyway. There’s a plethora of apps on HaikuDepot, some of the old BeOS titles have been ported over to Haiku which is nice.

I am very pleased and hope the HDA driver issue gets worked out eventually for my 64-bit system. I can’t add an audio card since there are no slots. . and OSS doesn’t even detect my hardware even after I blacklisted the HDA driver.

One thing I can’t seem to find is an x64 port of Quake, is there one out there? I tried compiling one but it seems the code is 32 bit and wont compile.

Keep it up, I will put a donation in for the bandwith I’ve used downloading software from HaikuDepot.


Haiku actually allowed my friend to have a general purpose computer. I inherited an old Acer netbook with Atom+2G RAM that wasn’t really enough for mainstream Linux distros. I slapped Haiku on it, installed Emacs and it runs beautifully. Now the friend is learning Python (along with Emacs-Lisp), and actually moving up the world. Impressed with Haiku’s ability to revive underpowered machines, and really thankful.


Curious, I have a Dell Optiplex 7010 USFF
(actually 4 of them, now 2)

I would be curious to dig out the spec sheet and compare, mine works fairly well, even supporting the internal speaker. Though I have noticed that plugging in speakers only works in the front port.

Are you sure it is using vesa driver and not the intel one? (assuming the hw is similar, have not checked yet)

I am very pleased and hope the HDA driver issue gets worked out eventually for my 64-bit system.

For this you might need to open a ticket at

Looks like there is tryquake_libretro, this woulf require installing RetroArch aswell, I don’t know how well that rund.

For Quake 2 there is Yamagi Quake II
and for Quake 3 arena there is OpenArena

Those were easyish to find, maybe you looked in the featured tab of haikudepot only?

Anyway, I hope thede pointers help a bit

1 Like

Here’s how listmage looks:

~> listimage | grep driver
   83 0xffffffff81a5c000 0xffffffff81a63000     0          0 /boot/system/add-ons/kernel/drivers/disk/virtual/ram_disk
  104 0xffffffff81a7a000 0xffffffff81a7b000     0          0 /boot/system/add-ons/kernel/drivers/dev/zero
  106 0xffffffff81fb9000 0xffffffff81fc3000     0          0 /boot/system/add-ons/kernel/drivers/dev/tty
  107 0xffffffff8203a000 0xffffffff8203b000     0          0 /boot/system/add-ons/kernel/drivers/dev/null
  108 0xffffffff8203c000 0xffffffff8203d000     0          0 /boot/system/add-ons/kernel/drivers/dev/dprintf
  109 0xffffffff81a64000 0xffffffff81a66000     0          0 /boot/system/add-ons/kernel/drivers/dev/console
  690 0xffffffff81e1f000 0xffffffff81e23000     0          0 /boot/system/add-ons/kernel/drivers/wmi
  865 0xffffffff82011000 0xffffffff82013000     0          0 /boot/system/add-ons/kernel/drivers/power/acpi_button
 2857 0xffffffff81f09000 0xffffffff81f0b000     0          0 /boot/system/add-ons/kernel/drivers/power/acpi_battery
 3819 0xffffffff81b67000 0xffffffff81b6b000     0          0 /boot/system/add-ons/kernel/drivers/dev/graphics/vesa
 3900 0xffffffff81f0c000 0xffffffff81f85000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/ipro1000
 4274 0xffffffff81e90000 0xffffffff81ea0000     0          0 /boot/system/add-ons/kernel/drivers/dev/input/usb_hid
 4609 0xffffffff8114c000 0xffffffff8114f000     0          0 /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw
 4664 0xffffffff8036f000 0xffffffff8037c000     0          0 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda
TEAM 1794 (/bin/grep --color=auto driver):

Note that if you are running the beta release, there were a lot of fixes to the HDA driver since then and it works on a lot more hardware now. At least my laptop originally didn’t work without the “warm reboot” trick, and now it works fine (at least speakers do anyway, I didn’t test headphones.)

Hey @waddlesplash I did try the beta after changing my repos over and updating. I kind of got audio if I played with the volume sliders but then it got garbled and muffled.

I am building another Haiku machine now. Found my old AMD machine in storage and it has a Sound Blaster 5.1 installed. Should be good times.