First impression: could not find any boot partition


#1

Read article on Slashdot about upcoming beta release
Downloaded haiku-master-hrev52323-x86_64-anyboot.zip
Extracted the ISO, mounted it on a fresh x64 VM in VMware
Kernel panic, could not find any boot partition
Verified VMware uses BIOS and not EFI boot.
Why in 2018 can’t boot loaders simply ask the user when in doubt instead of just crashing into a debugger?

BTW after I removed the virtual hard drive and tried again the ISO booted into the welcome screen/language selector. Kinda hard to install on a removed drive though so it doesn’t really help much.

Maybe I should try again after beta release?


#2

What you’ve tried out is not the official beta yet. The beta is still coming; please be patient.


#3

No, you should make a bugreport now at dev.haiku-os.org so we can investigate the problem. The beta release will use the same code, so if you don’t complain about problems, they will not disappear.

Also, this message is not from the bootloader. The bootloader already loaded the kernel, and then the kernel failed to find the system volume. The bootloader does ask when it can’t find a kernel to load.


#4

I am running into the same issue and I did not see an issue for it yet, so I created one: https://dev.haiku-os.org/ticket/14475

Let me know if you need more information or if I need to test something. I would really like to get it working.