Few problems

Hello Haiku community!
It was fun to use Be years ago .
At least i got my old laptop working! I was trying to install and try out haiku for a long time . But due dying harddrive , i was getting crashes on installation and starting up. Now i got myself another harddrive and was able to successfully install ans start Haiku . I was palying with it for few days now , installing different nighty builds . Right now i use 43976.
My laptop specs are :
Fujitsu Siemens S6010WB
1GHZ Pentium III
512 Ram
40 Gb HDD
Intel Extreme Graphics 2 (i830MG) - as screen configuration window shows me , so i suppose haiku use right driver
LAN is rtl8139 (Realtek RTL8139 PCI Fast Ethernet Adapter) - should be supported , i get link via DHCP , seems ok.
WIFI wavelanwifi ( Intersil ISL3874 , Prism 2.5 ) - Can’t get it working , don’t show any network
Intel 82801 AC’97 audio controller - was trying to get mp3 file playing - no sound

Laptop also have bluetooth, firewire and softmodem - don’t use it , so can’t comment

So i could have some help getting sound and wifi working on WPA-PSK network.

Bigger problem right now :
I can’t download any browser using Terminal and installoptionalpackage command . I was able to get some packages , like wpa_supplicant and few others, just fine , using lan connection. But every time i try to get some larger package loaded , computer just locks up . No KDL , no nothing , screen freezing , total lockup.
Is there any possibility to look what is crashing system ? Like process explorer or something?
Using ActivityMonitor , i saw 100% CPU use, when Terminal using command , but not in the moment it locks up . While downloading package CPU activity is around 20-30%

Need help here !

I was wondering , why Haiku have some demos and smaller utilities and stuff like that , but not any browser ? Can’t even read manual from desktop.

maybe problem with memory. you can run memtest (some livecd linux have memtest)

So far :
Checked laptop’s memory , 7 cycles no errors.
Tried same nightly on other computer , there other problems.
Downloaded BeZilla to my main computer , installed it to haiku from flashdrive. Working , slowly , using too much CPU , sometime haiku freezes as before.
Tried Vision , got some help there about sound problems .
Tried to get the sound working , as was described in Ticket #7284 . Don’t know , may be i’ve done something wrong , bu i created textfile called auich.settings in /boot/home/config/settings/kernel/drivers folder. Nothing. mp3 files not playing .
Had some problems with Bsnow demo . It got CPU to 100% Graphics was slowing down. And if you try to clean up desktop , all icons will be grabbed in one place. It took some time to get that Bsnow off and place all icons back. Trying to make reboot after takenig off Bsnow got me to KDL 3 times.

As i’ve posted before , i’ve done memory test . 9hours without any problems. So , that shouldn’t be the problem. Computer just locks up , screen freezes and that’s all.

try this command in console

listimage | grep accel

with this you get output of what video driver is used

after this look to console and write

installoptionalpackages -l

and after

installoptionalpackages -a webpositive

thats all…
i thins your sound card working, i have Realtek Azalia and works… when is failed then install opensouund driver…

with wifi i can not help, i dont have wifi card

Thx for your input!
BTW it’s “installoptionalpackage” without “s” .

Anyway , what’s done so far:
Today i installed win xp on this laptop. All went fine . Everything working as should . So hardware part should be ok . Bad news - wifi can only use wep , so i wont be trying it out under Haiku , don’t want to use less secure protocol just to try it out…
Then i installed last nightly bild (44007) on fresh partition. All went fine . Even boot manager correctly starting existing win xp .That is very good for that simple bootmanager.
As i wrote before , video drive is Intel Extreme graphics. listimage | grep accel shows the same. I would paste here result if i could , but i don’t have working browser in haiku right now.
But still ,installoptionalpackages -a webpositive crashes / lockes up Haiku. And that’s not all. Seems every large CPU or network activity lock the system up. It’s hard to reproduce .
But installing webbrowser crash it every time.
Also cpu cooler is working every time on max , but not in windows.

And i still can’t play any sound.

So , writing from Haiku !
Yesterday , with great help from diver_ in Vision , I got myself a browser.
Problem was with wifi driver , that conflicted with lan driver (IRQ conflict i suppose).That caused Haiku to completely freeze.
With manually disabled wifi driver in network preferences , i was able to download whatever i wanted. I need to do that every time i start haiku or just switch off wifi by button on laptop.

Also , again , with help from diver_ and SMCollins in Vision, i got sound to work now.
Somehow my soundcard wont work with ac97 driver . So i disabled auich driver and installed opensound.

Todays problem : Webpositive wont work anymore . Crashing at start with debug or ok (close) options. But i have Bezilla too :slight_smile:
EDIT : Little update , Actualy Webpositive starts to work . All ive done is : i just ignored that error message window , surfed a bit , closed it . And then next time i started , it worked again without an error. Writing in Web+ now :slight_smile: