DVD no boot, black screen, dots


#1

Hello all… didn’t want to hijack another thread and didn’t really find anything that was helpful from a search of the forums so figured I’d take the plunge…

Also, I find it awesome this project was born just down the Thruway from where I grew up in CNY :slight_smile:

Anyhow, I downloaded a nightly ISO a few days ago (haiku-nightly-hrev51497-x86_64-anyboot) and just burned it and all I get at boot is a string of periods (…) and then the screen goes black. Nothing from there. I actually downloaded the R1 Alpha 4.1 a few months back and had the same results.

I’m trying this on a Dell Precision M2800 Laptop. These are the specs that I could dig up… I’m going to assume someone will ask for more info but we’ll start here :slight_smile:

15.6-inch (1920 x 1080 pixel, 141 ppi) TFT display, matt-finish
2.8 GHz Intel Core i7-4810MQ (3.8 GHz Turbo)
Intel HD Graphics 4600 + AMD FirePro W4170M (2 GB memory)
Windows 7 Pro (64-bit)
8 GB DDR3L RAM
128 GB solid-state drive
802.11b/g/n/ac 2x2 MIMO
Bluetooth 4.0
1x HDMI 1.4, 1 x VGA
4 x USB 3.0
SDXC card slot
720p webcam/microphone
1x headphone socket


#2

Your Intel graphics is not currently supported. Tap the space bar during boot to enter the menu, and select VESA graphics mode. Reboot and you should be good to go.


#3

I’ll try right now… be back shortly :slight_smile:

Thanks.


#4

Ah unfortunately that did not work… I’ll have to try a different laptop this weekend. Luckily I have quote a few to play around with.


#5

He shouldn’t reboot but continue booting, otherwise he looses the setting.


#6

Sorry to be clear, the space bar does not do anything. I still get a black screen. And yes I wouldn’t want to reboot even if that did work :slight_smile:

I actually got to the boot screen and then to a blank desktop with a hand pointer in it by booting it via VMWare Workstation 12 Player… but no further no matter how long I wait. Hand moves with the mouse but it’s not an immediate refresh and no icons, etc.


#7

You mean you don’t see a menu after you press the space bar?
i’m asking this because the timing is a bit tricky.
Can you try booting from a usb stick to see how far it goes? but you need an anyboot or raw img to write to the stick.


#8

Correct, no menu… it just prints the periods and black screen no matter how many times I click the space bar. I’ll try the USB stick this weekend.


#9

Instead of the space bar, they holding down SHIFT. The Space bar trick worked well back when computers were really slow to boot.


#10

No boot logo, no boot menu either… I would start by chegking that the laptop is in legacy BIOS mode (UEFI is not officially supported yet) and maybe test that booting from another DVD works (some Linux system or so)

Note that you can also use an USB drive to boot Haiku, if you need to experiment it may avoid burning too many discs.


#11

Ok, it boots fine on another laptop so I suspect it could be something in the BIOS as stated above or something else. I’ll try the shift key as well when I have a free moment.


#12

Hey,
Not sure what the necro rules are here, so hopefully tacking on here is OK.
I’m in a similar position - trying to boot haiku gives nothing. Worked on my previous setup, but after recently upgrading it now won’t.
Initially I wrote current nightly 32-bit anyboot to a USB, booting it I see a cursor move down a couple lines, possibly some dots (it’s very quick, then screen goes black, coupel seconds later monitor stops receiving and system reboots.
Reading round here I found that there may be a problem with…xhci is it? so I figured i’d try writing the iso to a DVD and booting that, but it’s the same issue, except as it’s a slower boot I definately get a row of dots after the cursor jumps down a couple of lines.
In my BIOS compatability module is on, nothings overclocked or anything. Anyone got any thought/suggestions?
My setup is:
Motherboard: ASRock AMD AB350 Pro4 AM4
CPU: AMD Ryzen 3 1300X
RAM: 8GB (2x4GB) 2400MHz DDR4
Drive: 1TB SATA

Oh, should also say that again after reading here I have tried tapping space and holding down shift when booting - doesn’t seem to change anything :frowning:

Thanks :slight_smile:


#13

In your particular case i suspect the problem to be the Ryzen proc as it got only recently support from one of our devs, your model might be a little different than his, you should file a bug report about it and supply all the info the dev might need to complete the support for this proc and fix your booting problem.


#14

Hey,
Thank you for the reply - I’d seen a couple of bits about Ryzen dated a few months back, but they seemed to suggest Ryzens worked, I must have misunderstood ^_^;;
I’ve opened a bug - https://dev.haiku-os.org/ticket/13953 I’ve not attached a syslog as I don’t think it’ll have made one will it with it stopping that early? Actually, plus as it’s bootable media I assume it wouldn’t have been able to store it… If it still will have done somehow though I can probably get to it from my Linux install.
Thanks again :slight_smile:


#15

If you happen to have a COM port on this machine, it may be interesting to see if there is anything sent there before the crash. Maybe also try the 64-bit version of Haiku, it may behave differently.


#16

Hey,
Just tried the latest 64 bit image, same result i’m afraid.
My motherboard manual lists it’s got a COM port header, and a COM port shows up in device manager, what would I need to do to see if there’s any output from it?
Thanks :slight_smile:


#17

You will need another computer and some hardware to link the two together: null modem cable, COM header adapter (with the usual serial port plug), and probably an USB to RS232 adapter on the other side.

Then, on that other computer, run a serial terminal (gtkterm on Linux, SerialConnect on Haiku, cutecom, …) with settings 115200 bauds, 8N1. Then boot Haiku on the target machine and see if you get any output to the serial port.


#18

Hey there,
Apologies, I hadnt forgotten or ignored you, I just had to get the bits you suggested and then find an evening to fiddle with it all, as i’m very inexperienced in all this :slight_smile:
I have managed to get it working though, and got some output! I’m not sure if it’s any use to you - how do I go about attached it or getting it to you? Just upload to to google drive and share the link?
Thanks :slight_smile:


#19

I think the best way would be to create a ticket at dev.haiku-os.org and attach the output there. But if you don’t want to do that or don’t manage to create an account there, a google drive or whatever is fine.


#20

Assuming thats the bug tracker, I did create a ticket before after khallebal suggested it, but it quite quickly got closed as a duplicate, so I guess commenting on the bug its a duplicate of and attaching it there is best?