Drivesetup fails to create partitions

Hi all. I finally decided to set up Haiku on my Surface Pro 2. It was running Ubuntu till last night, but Linux, meh.

As it is 64bit and EFI, I went to set up the partition table. I removed the existing partitions, and that might have been my mistake as Drivesetup complained after deleting each one that it failed to delete them, but did anyway succeed. But after having a blank drive, I now can’t create any new partitions. It seems to fail every time. Anyone have an idea what I am doing wrong?

So I, selected the “-“ free space and “create” and tried to make the EFI data of 32MB. Error. Tried to create one for whole drive as BFS, failed. Rebooted, tried again, failed. I then tried whole drive as BFS, success and volume mounted. I then initialised with GUID and tried again. Fail. Tried Intel for a last ditch attempt, failed again.

It seems like it is the partition creation part that it is unhappy with. Is there a way to do this from the command line?

Oh, drive is reported as a “LITEON” and is 128GB in size. Haiku sees it, so I guess it should be okay?

Oh and Haiku, it’s a nightly. I don’t have the Greg version to hand but it was from about 2 or so weeks ago. I’ll find it later if that helps more.

While I can’t comment on the problem itself, I would suggest opening a ticket attaching syslog and a dump of the partition table like I was requested to do here.
As a workaround after reporting the ticket, I would suggest using a GParted USB stick to set the disk up.

It is actually the other way around, i mean you create first a partition table either “intel or GPT” then create your partitions as needed, you couldn’t create a table because the whole drive was already a partition at that point.
The fix for this is to wipe out that partition then as mentioned above create the table, one way to do that is with dd like this

dd if=/dev/zero of=/dev/disk/x/x/raw bs=2M count=10 status=progress

Edit: to create the partition table you should select the drive entry from the list not the empty space, if any.

1 Like

Just a small correction : one needs to delete the table, not only the partition, thus the need for the dd comand. In Windows a good old diskpart clean woulddo the same…

In this case my answer is still correct, as the partition is the whole disk, that’s why i chose the word partition and showed how to delete everything, as for dd i assumed he was doing this from haiku, and in haiku dd is the tool that is available.

So, just to clarify - disk already had Linux, therefore a partition table (GUID I assume). I deleted all the existing partitions (they were odd sizes and the EFI was way too big) and then tried to create individual partitions. That failed. I only formatted the entire drive to see if it would work. I then set it back up after the see if that would then work. The drive had a partition table initially. The rest is as described.

I will try dd, but given I already deleted the partition table by formatting the entire raw drive, seems more likely it is something else.

I will try gparted next.

This is what I get

Please try with a current nightly.

1 Like

Yes, that was the fix… I think my issue was exactly the same as another use reported.

So - it is now installed. WiFi works via a TPLink USB dongle (which seems to need to be in a hub for some reason - direct connection seems to fail…) But yeah - it works!!

The touch screen is also acting like a mouse, so I guess the driver “works” too - I will see if the pen works… yeah ben acts like a mouse. Tap is like left click, the button triggers right click… It has a WACOM digitiser, so I guess that is being seen as a mouse? Actually - after trying ArtPaint, it works perfectly as a pen :wink: