DosBox - issues with keyboard


#1

Hello. Since some revisions (x86_gcc2), apparently is something broken in DOSBox. The keymap is completely broken. I tried with several configurations in the .conf file, but no one appears to work. For example, I press ‘q’ key and appears an ‘s’.

The last time I remember that Dosbox worked well, was ay May-2015. Is posible that it could be a regression in Haiku code?
Anyone had the same problem? I’m currently using hrev49480.

Thank you!


#2

If it is a regression, that’s probably this ticket.


#3

DosBox uses “raw” key codes from SDL, and doesn’t handle the fact that these keycodes are different from one platform to another. You can edit the keymap in dosbox, or find an existing configuration file with the proper keymap.

This is not a regression, it has been this way forever as far as I can remember. Did you lose your dosbox configuration file?


#4

bbjimmy: thank you for your answer! I downloaded it from BeShare and works perfect! Thanks!!!

pulkomandy: it’s strange, because I remember that some time ago, I didn’t had this issue with the same version of Dosbox. The only changes was a few pkgman full-sync.

However, now will compare the dosbox.config from both apps (the “official” from HaikuDepot and the other from BeShare), and check if there are something different.

Thanks for your help!!!


#5

This has been a known issue for some time … try the dosbox zip file on BeShare … coquilletkd.com server from FAT ELK. It seems to work well. unzip anywhere and run.


#6

Hello. Sorry for the late response. I have some news about the Dosbox from the HaikuDepot:

I tried to use the same dosbox.conf file from the version obtained from BeShare in the Package version, but the problem persists.

I added a “mount” sentence in the dosbox.conf to check if the app read correctly the configuration file, and found the following: if I start the dosbox from terminal, Dosbox read the configuration file; but if I start it from the Tracker, didn’t.

In both cases (started from the Terminal or from the Tracker), the issue with the keyboard still exists (so, I think is not related to the dosbox.config file).


#7

This is most probably fixed with hrev49532, see ticket #12298.

Regards,
Humdinger


#8

I just checked on hrev50141, the issue persists. and the download still runs.


#9

Hopefully fixed in https://github.com/haikuports/haikuports/commit/2bc17.


#10

YAY, Diskmags and DosNavigator on Haiku! Have to test them at night.


#11

Here you can use a shell Script to solve this problem.

http://old.besly.de/menu/search/archiv/dev/startscript-terminal-apps_eng.html

Or you create a c app to do it:

http://old.besly.de/menu/search/archiv/dev/shellscript_c.html


#12

Hello! Thanks for the advice.

If I remember correctly, the issue can be resolved editing the dosbox.config file, and changing the parameter ‘usescancodes’ and set it to false.