Crash after updating to mesa 17.1.10-2


After installing on real hardware “R1 Beta 1 Testing Image - Pre-RC” from kallisti5, everything seems to work correctly.
Then I run SoftwareUpdater and the following updates are available:

  • less
  • mesa
  • mesa_devel
  • mesa_swipe
  • tiff4
    After reboot, the demos “GLTeapot” and “Haiku3d” crash.

Just to be sure, I made again a clean install, ran the 2 demos (it was ok), ran the updater and ran again the 2 demos, then it crashed again.

Does anybody get the same problem?

This is a forum, please report bugs at the site, but only after checking if somebody already created a ticket for your problem. You will see, @cocobean already did it.

Not to contradict @extrowerk, but before opening another ticket, have you tried doing an upgrade from a clean install of the testing image on your machine? From everything, that’s what I’m getting here.

The test build is most likely not in the most stable state to be doing upgrades to it. Instead, my advice would be to either stick with the pre-rc build for now or switch back to the nightly branch and wait until the official rc arrives before trying to perform system updates.

Anyway, just my little opinion, which may or may not help, but I’m hoping it helps.

We are close to a beta, and we need bugreports. No matter what you tried and how you got into a problem, make bugreports.
We can then decide they won’t affect beta users, and keep them for later. But this is a decision to be made by the developers.
If you have a problem, report a bug immediately.

You are right @miglas, it is the same problem as @cocobean

I have 2 OpenGL projects using Mesa (x64), and they both work with hrev52309. Nothing has broken for me.

There is one interesting point about one of the projects, I always have to rebuild it after a Haiku update otherwise it just sits there doing nothing - not even the initial printf in main() gets displayed before I even initialise an OpenGL context, and this seriously corrupts Haiku state that a reboot is necessary. Rebuilding it and it’s fine. The 2nd project doesn’t have this issue (it always runs fine). Both use the same engine … I suspect the issue is with XHCI driver (since I boot from USB hard disk), and recompiling the larger game impacts the memory caches and doesn’t reveal the problem.