Corrupt zip files

When trying to transfer syslog files from one Haiku PC to another, I zip the log folder containing the syslog files and copy the zip file to a USB stick. However, upon copying the zip archive on to the second PC and opening the archive, the contents are unreadable - looking like some kind of binary code. Could this be a bug in the Haiku zip archiver? If I go back to the first PC and open the zip file I created, all is well. It appears to be getting corrupted during the copy process.

Have you tried another USB stick?

I once have a zip file that would not copy on one USB stick, but worked fine on others.

Also the first stick was formatted as BeFS and once I reformatted it to FAT32 the file copied fine. Weird. But it was one of the early 32GB sticks so it may had a bad data block or flaky compression. I got rid of it a long time ago (IE. someone borrowed it and never returned it).

If the USB stick is formatted with BFS first, then there is no problem. However, if the stick is formatted with FAT or NTFS when the zip is copied to it, the file becomes corrupt. In one instance, I opened the zip in Windows, and found that the files inside contained readable pieces of data that had previously been deleted from the stick. I do not believe this should be occurring with zipped archives.

BeFS and FAT32 will write the same file to diffirent locations on a USB drive. This sound like a bad block in the stick. Like I said, I got rid of the problem unit and go a diffirent one and had no problems since.