Colour band on boot

I have just tried the Haiku Alpha LiveCD and when I try and boot it, instead of the splash screen I get a coloured band on the top left of the screen (|red|blue|yellow|green|etc|). I am using an Intel Corporation 82815 Chipset Graphics Controller and I have a 1Ghz Dell machine.

That sounds like a badly mismatched scan rate.

Loads and runs with superb graphics and extremely clear text on Lenovo G400 3000 with Intel 82945GM chipset. Auto-sizes to the native 1280x800x32.

On the other two machines I have tried:

IBM Thinkpad X20 667 MHz, with ATI Rage Mobility it also autodetects the native 1024x768 and is very clear.

VIA C6 with embedded S3 Unichrome, it correctly reports the Philips 200WS (which is native 1680x1050), but runs it at 1600x1200. Still has decent clarity.

AFAICS, R1 uses the VESA 2 or VESA 3 drivers anyway…

I could be wrong, but it should at least show the banner logo with rounded-corner rectangular boot-stage icons below it on any VGA prior to completing the boot.

Does your boot media work on another machine?

Might you have a bad CD image?

And JFWIW, the latest Xorg 7.X will NOT (yet) run on my Lenovo / Intel, despite a good deal of fiddlign with drivers and Options, though 6.9 was happy w/o even a config file.

While Haiku is booting, press [space bar] to enter safe mode options.

  1. select use fail-safe video mode
  2. choose a fail-safe resolution, ie: 1024x768x32

Likely the Intel video driver does not work with your graphics card and by doing the above you’ll boot with VESA driver & with supported resolution.

Ok, I will try that now.

I have changed to an ATI Radeon graphics card and it all works!