Can't get the Input Kit to work anymore


I have been building the Haiku tree and the packages for many months now, and I suppose in December sometime I noticed that the Input Kit would always end up hosing my system. I thought it would be a temporary thing, but every build I do results in a built Input Kit that doesn’t do anything but hang up my computer on bootup. After this happens, I revert to the original input kit, and everything is happy again.

In other words, months ago I was building it just fine, trying out a new build every few days. Then I did a CVS update one day and rebuilt the kit, only to find it hosing my system every time. After about a week, I figured I must be missing some kind of flag or something to ensure it builds correctly.

I am currently running an R5 + BONE system, as I was before when eveything used to build just fine. I tried using stuff like COMPILE_FOR_R5=1 (which I’m guessing is now deprecated), as well as using the --target=bone switch for “configure.” (I even tried --target=r5 just in case.) Most everything else I build seems to work fine, so could someone tell me EXACTLY what I need to do to get a working drop-in replacement build of the input kit? By “exactly,” I mean any kind of switches for “configure” and maybe any other flags I need to explicitly set in my .profile, or when running “jam” or “jam packages.”

I’ve tried multiple compilers (geekgadgets, 2.95.3, etc.) and multiple build environments now, and I can’t get a working input server for the life of me.

I see plenty of CVS commits to it, so I know that the kit must be working somewhat for at least jackburton and some others.

Any kind of advice on this matter is appreciated. If no suggestions can be given, information on obtaining a working copy of a recent CVS built R5 drop-in version of the input kit would be helpful.

Thanks in advance.


Try this:
compile as usual, but after install, remove (or just move) the serial_mouse addon.
Then see if the problem is gone.

If that the case, please drop me a line to “bipolar [AT]”.

Maybe my addon is causing problems on your system (ain’t 100% finished/tested :-()


Well, I finally got this resolved after lots of trial and error.

In the end, I had to remove the serial_mouse addon like suggested above to prevent the input server from crashing upon bootup. I also had to play with the setting COMPILE_FOR_R5=1 and the --target flag for configure. Eventually I got something that worked.

Thanks to BiPolar for helping me figure out where things went wrong.