Can't continue booting

Quick question… I ran SoftwareUpdater today on my hardware Haiku box, and when it rebooted it went straight to a while screen with a bunch of messages about DwarfManager.

I tried to select an earlier boot volume, but no matter which one I select, the “Continue Booting” option is disabled.

Is there any easy way to fix a problem like this?

That sounds like an app_server crash. It seems extremely strange that you would get one on boot…

It also seems very odd you cannot continue booting. Is this an EFI install? You may want to update your EFI loader (which you can do from another OS), there was a bug some time ago that prevented older volumes from being booted, but this has since been fixed.

1 Like

Yes, it is app_server. It is an EFI system, so I’ll try and update that and see how it goes.

Still curious about the DwarfManager…

This is what it looks like, if you’re curious.

I changed the EFI and now I can select an older boot volume, so it’s back in action. Thanks!

Can you get stack trace of crash (bt command)? Also what are last working and broken versions?

No, there was no keyboard input. The screen also kept changing, so it wasn’t quite done crashing. I’m not sure about last working and broken versions. I’ll need some time to get that.

However, I did try booting from the latest version but used the safe video option, and that let it boot up again. I never had to mess with the boot options before, maybe it was something in video? Hrev 54415 is what’s on there now, with the safe video selected.

Scrolling should stop if wait some time. After that it should be possible to type commands.

Okay, here it is. Also, guessing it’s the Radeon driver.


A bounch of Radeon PCI ID was added lately to the supported hw list in the driver, could you check whats your PCI ID is, maybe yours got mistakenly added.

Yes, @kallisti5’s recent change is probably related indeed.

1 Like

Yep, here is it :

1 Like

If thats the case we should open a bug report against this change to track this issue.

I reckon you are correct.

My Radeon Hd PC 32bit does not start after updating this morning!
It will switch after the rocket icon to the card driver and then it stalls.
This card is known to work, and there where no problems until today.

But did Haiku used the radeon driver before, or did it an automatic fallback to vesa?
Could you please check it with booting an earlier state and grep the listimage output like
‘listimage | grep radeon’
and posting the output here?

For me, listimage | grep radeon doesn’t return anything. Vesa does return something, though:

listimage | grep vesa
2617 0xffffffff82504000 0xffffffff82508000 0 0 /boot/system/add-ons/kernel/drivers/dev/graphics/vesa
2626 0x0000007739ecf000 0x000000773a0d3000 0 0 /boot/system/add-ons/accelerants/vesa.accelerant

listdev shows:
device Display controller (VGA compatible controller, VGA controller) [3|0|0]
vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI]
device 15d8: Picasso

Your ID was added with the referred commit, in the last line:

+ {0x15d8, 13, 0, RADEON_RAVEN, CHIP_APU, "Radeon Vega Raven"},

It means the radeon driver didn’t even tried to drive your card before, this is why listimage didn’t returned anything for radeon.

It is either

  • an incompatible, newer generation card than what the radeon driver supports / handles and was mistakenly added, or
  • the hw is a bit different than the others in its family (unlikely, but i have no experiences with Radeon since R600)
  • or the driver is broken for this card and eventually for its whole family or for even more.

There is nothing you can do right now, the referred line should be (temporarily) removed till it gets fixed, so basically you would get back the vesa driven desktop. If you feel the force you can propose a patch at .

Please at least submit a bugreport even if you don’t do the patch yourself, this way we can link to it in a comment in the code and remember why it is disabled and we can contact you through the bugtracker when we want you to try again with a fixed driver.

Already done: